summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-16 17:26:45 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-16 17:26:45 +0100
commit208f4e107c78b00c3bdf09301d1b1e43e1b9fdf8 (patch)
tree3f7cb79d710602f4c33ebf6341bb27822e5f718c /Makefile.am
parent446a982c2b8f77eb0e349e5bd8240ece6a0772bd (diff)
downloadrsyslog-208f4e107c78b00c3bdf09301d1b1e43e1b9fdf8.tar.gz
rsyslog-208f4e107c78b00c3bdf09301d1b1e43e1b9fdf8.tar.xz
rsyslog-208f4e107c78b00c3bdf09301d1b1e43e1b9fdf8.zip
added output module template
so far, this is mostly some documentation, but I hope that during the process of creating output modules out of it we will get good questions and thus can extend the template. In any case, it should be better than what we had so far...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index aaca570d..7bb6af8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,6 +88,10 @@ if ENABLE_IMTEMPLATE
SUBDIRS += plugins/imtemplate
endif
+if ENABLE_OMTEMPLATE
+SUBDIRS += plugins/omtemplate
+endif
+
if ENABLE_IMFILE
SUBDIRS += plugins/imfile
endif
@@ -114,5 +118,5 @@ SUBDIRS += tests
# temporarily be removed below. The intent behind forcing everthing to compile
# in a make distcheck is so that we detect code that accidently was not updated
# when some global update happened.
-DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls
+DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls
ACLOCAL_AMFLAGS = -I m4