summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-03-07 08:06:16 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-03-07 08:06:16 +0000
commitfa67273c1644551b50919fa7879acfdc92e269bc (patch)
tree38e41ee526a4bcc19540047c56c93b2a7865ef36 /Makefile.am
parentae3e3e9cb1584b5cf7082c1b28c4cbbd48b1f664 (diff)
downloadrsyslog-fa67273c1644551b50919fa7879acfdc92e269bc.tar.gz
rsyslog-fa67273c1644551b50919fa7879acfdc92e269bc.tar.xz
rsyslog-fa67273c1644551b50919fa7879acfdc92e269bc.zip
- added RSYSLOGD_MODDIR environment variable
- added -M rsyslogd option (allows to specify module directory location) - converted net.c into a loadable library plugin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 67b3e962..c4fc4b68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,8 +50,6 @@ rsyslogd_SOURCES = \
queue.h \
sync.c \
sync.h \
- net.c \
- net.h \
obj.c \
obj.h \
obj-types.h \
@@ -111,6 +109,17 @@ tcpsrv_la_LDFLAGS = -module -avoid-version
tcpsrv_la_LIBADD =
#
+# network support
+#
+if ENABLE_INET
+pkglib_LTLIBRARIES += net.la
+net_la_SOURCES = net.c net.h
+net_la_CPPFLAGS = $(pthreads_cflags)
+net_la_LDFLAGS = -module -avoid-version
+net_la_LIBADD =
+endif
+
+#
# gssapi support
#
if ENABLE_GSSAPI