summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-03-12 14:08:21 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-03-12 14:08:21 +0000
commit618a7f6a220563a50909d0e15eb90ce222aced31 (patch)
tree484439581a66494bbed91aa6e53f4b571126e820 /Makefile.am
parent9ddee5b38772f42f4371c6828a832f0d6267251d (diff)
downloadrsyslog-618a7f6a220563a50909d0e15eb90ce222aced31.tar.gz
rsyslog-618a7f6a220563a50909d0e15eb90ce222aced31.tar.xz
rsyslog-618a7f6a220563a50909d0e15eb90ce222aced31.zip
changed omgssapi and omfwd to utilize new object calling interface; made a
tcpclt class; (stage work, among others, for more intelligent recovery from TCP session recovery)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 22 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b3253f9..7bdec73a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,10 +94,20 @@ rsyslogd_LDADD = $(zlib_libs) $(pthreads_libs) $(dl_libs) $(rt_libs)
rsyslogd_LDFLAGS = -export-dynamic
# now come the library plugins
-pkglib_LTLIBRARIES = lmtcpsrv.la
+pkglib_LTLIBRARIES =
+if ENABLE_INET
+pkglib_LTLIBRARIES += lmnet.la lmtcpsrv.la lmtcpclt.la
+#
+# network support
+#
+lmnet_la_SOURCES = net.c net.h
+lmnet_la_CPPFLAGS = $(pthreads_cflags)
+lmnet_la_LDFLAGS = -module -avoid-version
+lmnet_la_LIBADD =
+#
#
-# TCP (Stream) Server support
+# TCP (stream) server support
#
lmtcpsrv_la_SOURCES = \
tcps_sess.c \
@@ -109,15 +119,16 @@ lmtcpsrv_la_LDFLAGS = -module -avoid-version
lmtcpsrv_la_LIBADD =
#
-# network support
-#
-if ENABLE_INET
-pkglib_LTLIBRARIES += lmnet.la
-lmnet_la_SOURCES = net.c net.h
-lmnet_la_CPPFLAGS = $(pthreads_cflags)
-lmnet_la_LDFLAGS = -module -avoid-version
-lmnet_la_LIBADD =
-endif
+# TCP (stream) client support
+#
+lmtcpclt_la_SOURCES = \
+ tcpclt.c \
+ tcpclt.h
+lmtcpclt_la_CPPFLAGS = $(pthreads_cflags)
+lmtcpclt_la_LDFLAGS = -module -avoid-version
+lmtcpclt_la_LIBADD =
+
+endif # if ENABLE_INET
#
# regular expression support