summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-03-07 16:10:58 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-03-07 16:10:58 +0000
commit549c0cccd44dc36a6ba8c480fa65bcaad6cb20ec (patch)
treeed166a3d83210c30502825d644f5be40a9624b08 /Makefile.am
parent1888852c9a59631771efb5975aa51ddb0305ceb2 (diff)
downloadrsyslog-549c0cccd44dc36a6ba8c480fa65bcaad6cb20ec.tar.gz
rsyslog-549c0cccd44dc36a6ba8c480fa65bcaad6cb20ec.tar.xz
rsyslog-549c0cccd44dc36a6ba8c480fa65bcaad6cb20ec.zip
extracted regexp functionality to its own dynamically loadable module
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c4fc4b68..1fc48c18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -120,6 +120,17 @@ net_la_LIBADD =
endif
#
+# regular expression support
+#
+if ENABLE_REGEXP
+pkglib_LTLIBRARIES += regexp.la
+regexp_la_SOURCES = regexp.c regexp.h
+regexp_la_CPPFLAGS = $(pthreads_cflags)
+regexp_la_LDFLAGS = -module -avoid-version
+regexp_la_LIBADD =
+endif
+
+#
# gssapi support
#
if ENABLE_GSSAPI