summaryrefslogtreecommitdiffstats
path: root/libpoldiff/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libpoldiff/swig/Makefile.am')
-rw-r--r--libpoldiff/swig/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/libpoldiff/swig/Makefile.am b/libpoldiff/swig/Makefile.am
new file mode 100644
index 0000000..3412858
--- /dev/null
+++ b/libpoldiff/swig/Makefile.am
@@ -0,0 +1,15 @@
+if DO_SWIGIFY_PYTHON
+ MAYBE_PYSWIG = python
+endif
+
+if DO_SWIGIFY_JAVA
+ MAYBE_JSWIG = java
+endif
+
+if DO_SWIGIFY_TCL
+ MAYBE_TCLSWIG = tcl
+endif
+
+SUBDIRS = $(MAYBE_PYSWIG) $(MAYBE_JSWIG) $(MAYBE_TCLSWIG)
+
+dist_noinst_DATA = poldiff.i