summaryrefslogtreecommitdiffstats
path: root/sigencore/plugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sigencore/plugins/CMakeLists.txt')
-rw-r--r--sigencore/plugins/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/sigencore/plugins/CMakeLists.txt b/sigencore/plugins/CMakeLists.txt
new file mode 100644
index 00000000..bc683fc1
--- /dev/null
+++ b/sigencore/plugins/CMakeLists.txt
@@ -0,0 +1,47 @@
+project(plugins)
+
+set(sigencoreplugins_HEADERS
+ ArenaPlugin.h
+ Global.h
+)
+set(sigencoreplugins_SRCS
+ ArenaPlugin.cpp
+)
+
+kde4_add_library(sigencoreplugins
+ SHARED
+ ${sigencoreplugins_SRCS}
+)
+set_target_properties(sigencoreplugins
+ PROPERTIES
+ VERSION ${SIGEN_VERSION}
+ SOVERSION ${SIGEN_SOVERSION}
+)
+target_link_libraries(sigencoreplugins
+ ${KDE4_KDEUI_LIBRARY}
+ sigencore
+)
+target_link_libraries(sigencoreplugins LINK_INTERFACE_LIBRARIES
+ ${KDE4_KDEUI_LIBRARY}
+ sigencore
+)
+
+install(
+ TARGETS
+ sigencoreplugins
+ EXPORT
+ sigen_EXPORTS
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}
+ COMPONENT
+ runtime
+)
+
+install(
+ FILES
+ ${sigencoreplugins_HEADERS}
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/include/sigencore/plugins
+ COMPONENT
+ development
+)