summaryrefslogtreecommitdiffstats
path: root/present/python-pyfiglet/python-pyfiglet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'present/python-pyfiglet/python-pyfiglet.spec')
-rw-r--r--present/python-pyfiglet/python-pyfiglet.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/present/python-pyfiglet/python-pyfiglet.spec b/present/python-pyfiglet/python-pyfiglet.spec
new file mode 100644
index 0000000..24388d0
--- /dev/null
+++ b/present/python-pyfiglet/python-pyfiglet.spec
@@ -0,0 +1,57 @@
+%global pypi_name pyfiglet
+
+Name: python-%{pypi_name}
+Version: 0.8.post1
+Release: 1%{?dist}
+Summary: Pure-python FIGlet implementation
+
+License: MIT
+URL: https://github.com/pwaller/pyfiglet
+Source0: %{pypi_source}
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3dist(setuptools)
+
+%global _description %{expand:
+pyfiglet is a full port of FIGlet (http://www.figlet.org/) into pure python. It
+takes ASCII text and renders it in ASCII art fonts (like the title above, which
+is the 'block' font).}
+
+%description %{_description}
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+%{?python_provide:%python_provide python3-%{pypi_name}}
+
+Requires: python3dist(setuptools)
+
+%description -n python3-%{pypi_name} %{_description}
+
+%prep
+%autosetup -n %{pypi_name}-%{version}
+# Remove bundled egg-info
+rm -rf %{pypi_name}.egg-info
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+# Resolve RPMLint errors
+sed -i '1d' %{buildroot}%{python3_sitelib}/%{pypi_name}/{__init__,test}.py
+
+install -Dpm 0644 -t %{buildroot}%{_mandir}/man1/ doc/%{pypi_name}.1
+
+%files -n python3-%{pypi_name}
+%doc README doc/figfont.txt
+%license LICENSE
+%{_bindir}/%{pypi_name}
+%{_mandir}/man1/%{pypi_name}.1.*
+%{python3_sitelib}/%{pypi_name}
+%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
+
+%changelog
+* Fri Sep 04 2020 Lyes Saadi <fedora@lyes.eu> - 0.8.post1-1
+- Initial package