summaryrefslogtreecommitdiffstats
path: root/uboot-tools.spec
diff options
context:
space:
mode:
authorDan Horák <sharkcz@fedoraproject.org>2010-06-04 14:19:00 +0000
committerDan Horák <sharkcz@fedoraproject.org>2010-06-04 14:19:00 +0000
commit5c9ad741162a2dacc364e55248d2d088f679d17f (patch)
tree8164fba2cffea13820168ea0b971c09cfc149a97 /uboot-tools.spec
parentf92ea64a084e2dedbef162b8007896d6ab95bbcd (diff)
downloaduboot-tools-5c9ad741162a2dacc364e55248d2d088f679d17f.tar.gz
uboot-tools-5c9ad741162a2dacc364e55248d2d088f679d17f.tar.xz
uboot-tools-5c9ad741162a2dacc364e55248d2d088f679d17f.zip
initial import
Diffstat (limited to 'uboot-tools.spec')
-rw-r--r--uboot-tools.spec69
1 files changed, 69 insertions, 0 deletions
diff --git a/uboot-tools.spec b/uboot-tools.spec
new file mode 100644
index 0000000..bff0209
--- /dev/null
+++ b/uboot-tools.spec
@@ -0,0 +1,69 @@
+Name: uboot-tools
+Version: 2010.03
+Release: 1%{?dist}
+Summary: U-Boot utilities
+
+Group: Development/Tools
+License: GPLv2+
+URL: http://www.denx.de/wiki/U-Boot
+Source0: ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
+Patch0: u-boot-2010.03-env-makefile.patch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+
+%description
+This package contains a few U-Boot utilities - mkimage for creating boot images
+and fw_printenv/fw_setenv for manipulating the boot environment variables.
+
+
+%prep
+%setup -q -n u-boot-%{version}
+%patch0 -p1
+
+
+%build
+make sheevaplug_config
+
+# create files normally created by cross-compiler
+touch include/autoconf.mk
+touch include/autoconf.mk.dep
+touch {cpu/arm926ejs,examples/standalone,tools,tools/env}/.depend
+
+make tools HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true CROSS_COMPILE=""
+make env CC="gcc $RPM_OPT_FLAGS"
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+mkdir -p $RPM_BUILD_ROOT%{_bindir}
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
+
+install -p -m 0755 tools/mkimage $RPM_BUILD_ROOT%{_bindir}
+install -p -m 0755 tools/env/fw_printenv $RPM_BUILD_ROOT%{_bindir}
+( cd $RPM_BUILD_ROOT%{_bindir}; ln -sf fw_printenv fw_setenv )
+
+install -p -m 0644 tools/env/fw_env.config $RPM_BUILD_ROOT%{_sysconfdir}
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc COPYING README doc/uImage.FIT
+%{_bindir}/mkimage
+%{_bindir}/fw_printenv
+%{_bindir}/fw_setenv
+%config(noreplace) %{_sysconfdir}/fw_env.config
+
+
+%changelog
+* Thu May 27 2010 Dan Horák <dan[at]danny.cz> 2010.03-1
+- updated to to 2010.03
+- applied review feedback - added docs and expanded description
+- pass proper CFLAGS to the compiler
+
+* Sat Nov 14 2009 Dan Horák <dan[at]danny.cz> 2009.08-1
+- initial Fedora version