summaryrefslogtreecommitdiffstats
path: root/rubygem-typhoeus.spec
diff options
context:
space:
mode:
authorVít Ondruch <vondruch@redhat.com>2011-11-28 13:36:14 +0100
committerVít Ondruch <vondruch@redhat.com>2011-11-28 13:36:14 +0100
commitf52c365558f3d32bd4ea776522dec3a762a887b4 (patch)
treeae23108bfbe33cb54ddadb5876d5d8cd3fe89b06 /rubygem-typhoeus.spec
parentb375f01c8630de02b6d02a666264e6b4e095a2cc (diff)
downloadrubygem-typhoeus-f52c365558f3d32bd4ea776522dec3a762a887b4.tar.gz
rubygem-typhoeus-f52c365558f3d32bd4ea776522dec3a762a887b4.tar.xz
rubygem-typhoeus-f52c365558f3d32bd4ea776522dec3a762a887b4.zip
Updated to typhoeus 0.3.3.
Diffstat (limited to 'rubygem-typhoeus.spec')
-rw-r--r--rubygem-typhoeus.spec84
1 files changed, 23 insertions, 61 deletions
diff --git a/rubygem-typhoeus.spec b/rubygem-typhoeus.spec
index 55da661..bd6549b 100644
--- a/rubygem-typhoeus.spec
+++ b/rubygem-typhoeus.spec
@@ -1,28 +1,28 @@
+%global gemname typhoeus
+
%global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] ')
%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
-%global gemname typhoeus
%global geminstdir %{gemdir}/gems/%{gemname}-%{version}
%global rubyabi 1.8
Summary: A library for interacting with web services at blinding speed
Name: rubygem-%{gemname}
-Version: 0.2.0
-Release: 2%{?dist}
+Version: 0.3.3
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://github.com/pauldix/typhoeus
Source0: http://gems.rubyforge.org/gems/%{gemname}-%{version}.gem
-Patch0: %{name}-gcc-flags-fix.patch
-Requires: rubygems
+Requires: ruby(rubygems)
Requires: ruby(abi) = %{rubyabi}
-Requires: rubygem(rack)
+Requires: rubygem(mime-types)
BuildRequires: ruby(abi) = %{rubyabi}
-BuildRequires: rubygems
-BuildRequires: rubygem(rspec)
-BuildRequires: rubygem(rake)
-BuildRequires: rubygem(rack)
-BuildRequires: rubygem(diff-lcs)
+BuildRequires: ruby(rubygems)
+# Use rspec-core until rspec are not migrated to RSpec 2.x
+BuildRequires: rubygem(rspec-core)
BuildRequires: rubygem(json)
+BuildRequires: rubygem(mime-types)
+BuildRequires: rubygem(sinatra)
BuildRequires: ruby-devel
BuildRequires: libcurl-devel
Provides: rubygem(%{gemname}) = %{version}
@@ -49,23 +49,16 @@ gem install \
--install-dir ./%{gemdir} \
-V --force --rdoc \
%{SOURCE0}
-pushd .%{geminstdir}
-%patch0
-popd
%build
-pushd .%{geminstdir}/ext/%{gemname}
-(%_bindir/ruby extconf.rb && make clean all)
-popd
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{gemdir}
cp -a ./%{gemdir}/* %{buildroot}%{gemdir}
+
mkdir -p %{buildroot}%{ruby_sitearch}/%{gemname}
-mv -f %{buildroot}%{geminstdir}/ext/%{gemname}/*.so %{buildroot}%{ruby_sitearch}/%{gemname}
-rm -rf %{buildroot}%{geminstdir}/ext
-find %{buildroot}/%{geminstdir} -name .gitignore | xargs rm -f
+mv -f %{buildroot}%{geminstdir}/lib/%{gemname}/*.so %{buildroot}%{ruby_sitearch}/%{gemname}
# remove all shebang, set permission to 0644 (mtasaka)
for f in $(find %{buildroot}%{geminstdir} -name \*.rb)
@@ -76,64 +69,33 @@ done
%check
pushd .%{geminstdir}
-ln -sf %{buildroot}%{ruby_sitearch}/%{gemname}/native.so lib/%{gemname}/native.so
-
-NEEDSKIP=""
-for needskip in \
- spec/%{gemname}/request_spec.rb \
- spec/%{gemname}/hydra_spec.rb \
- spec/%{gemname}/remote_spec.rb \
- spec/%{gemname}/multi_spec.rb \
- spec/%{gemname}/easy_spec.rb \
- spec/%{gemname}/remote_proxy_object_spec.rb
-do
- NEEDSKIP="$NEEDSKIP $needskip"
-done
-
-for needskip in $NEEDSKIP
-do
- mv $needskip ${needskip}.save
-done
-
-rake spec --trace
-
-for needskip in $NEEDSKIP
-do
- mv ${needskip}.save $needskip
-done
-
-rm -f lib/%{gemname}/native.so
-
+rspec spec
popd
-%clean
-rm -rf %{buildroot}
-
%files
-%defattr(-, root, root, -)
%dir %{geminstdir}
%dir %{ruby_sitearch}/%{gemname}
+%exclude %{geminstdir}/ext
%{geminstdir}/lib
+%exclude %{geminstdir}/lib/typhoeus/.gitignore
%{ruby_sitearch}/%{gemname}/*.so
-%doc %{geminstdir}/VERSION
-%doc %{geminstdir}/README.textile
-%doc %{geminstdir}/CHANGELOG.markdown
-%{gemdir}/cache/%{gemname}-%{version}.gem
+%doc %{geminstdir}/LICENSE
+%exclude %{gemdir}/cache/%{gemname}-%{version}.gem
%{gemdir}/specifications/%{gemname}-%{version}.gemspec
%files doc
-%defattr(-, root, root, -)
+%doc %{geminstdir}/CHANGELOG.markdown
%{geminstdir}/Rakefile
%{geminstdir}/Gemfile
%{geminstdir}/Gemfile.lock
%{geminstdir}/spec
-%{geminstdir}/benchmarks
-%{geminstdir}/examples
-%{geminstdir}/profilers
%{geminstdir}/%{gemname}.gemspec
-%{gemdir}/doc/%{gemname}-%{version}
+%doc %{gemdir}/doc/%{gemname}-%{version}
%changelog
+* Mon Nov 28 2011 Vít Ondruch <vondruch@redhat.com> - 0.3.3-1
+- Updated to typhoeus 0.3.3.
+
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild