summaryrefslogtreecommitdiffstats
path: root/rubygem-rails.spec
diff options
context:
space:
mode:
authorMamoru Tasaka <mtasaka@fedoraproject.org>2009-07-30 17:31:17 +0000
committerMamoru Tasaka <mtasaka@fedoraproject.org>2009-07-30 17:31:17 +0000
commit3e2b749dc5ffc3ce5d714bba9c8fbbe82d69b7b4 (patch)
treefd28206491df7b96049ca5714766742de5b88f31 /rubygem-rails.spec
parent0da828f518c2ad89d3bf9a64c60f23582ecb0a5d (diff)
downloadrubygem-rails-3e2b749dc5ffc3ce5d714bba9c8fbbe82d69b7b4.tar.gz
rubygem-rails-3e2b749dc5ffc3ce5d714bba9c8fbbe82d69b7b4.tar.xz
rubygem-rails-3e2b749dc5ffc3ce5d714bba9c8fbbe82d69b7b4.zip
- Restore some changes
Diffstat (limited to 'rubygem-rails.spec')
-rw-r--r--rubygem-rails.spec26
1 files changed, 19 insertions, 7 deletions
diff --git a/rubygem-rails.spec b/rubygem-rails.spec
index cbe208d..3cd5ac6 100644
--- a/rubygem-rails.spec
+++ b/rubygem-rails.spec
@@ -7,15 +7,14 @@
Summary: Web-application framework
Name: rubygem-%{gemname}
Version: 2.3.3
-Release: 1%{?dist}
+Release: 2%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
Source0: http://gems.rubyforge.org/gems/%{gemname}-%{version}.gem
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: ruby(rubygems) >= 1.1.1
-Requires: rubygem(rake) >= 0.7.2
-Requires: rubygem(rack) >= 1.0.0
+Requires: rubygem(rake) >= 0.8.3
Requires: rubygem(activesupport) = %{version}
Requires: rubygem(activerecord) = %{version}
Requires: rubygem(actionpack) = %{version}
@@ -23,7 +22,6 @@ Requires: rubygem(actionmailer) = %{version}
Requires: rubygem(activeresource) = %{version}
BuildRequires: rubygems
-BuildRequires: rubygem(rack) >= 1.0.0
BuildArch: noarch
Provides: rubygem(%{gemname}) = %{version}
@@ -42,6 +40,7 @@ Oracle with eRuby- or Builder-based templates.
rm -rf %{buildroot}
mkdir -p %{buildroot}%{gemdir}
gem install --local --install-dir %{buildroot}%{gemdir} \
+ -V \
--force %{SOURCE0}
mkdir -p %{buildroot}/%{_bindir}
mv %{buildroot}%{gemdir}/bin/* %{buildroot}/%{_bindir}
@@ -51,22 +50,26 @@ find %{buildroot}%{geminstdir}/bin -type f | xargs chmod a+x
# Cleanup some upstream packaging oddities, mostly to make rpmlint happy
sed -i '1i#!/usr/bin/ruby\n' %{buildroot}%{geminstdir}/bin/rails
+# ref: bug 496480
for file in `find %{buildroot}/%{geminstdir}/ -type f -perm /a+x`; do
- sed -i -e '1c#!/usr/bin/ruby' $file
+ sed -i -e '1s|%{_bindir}/env ruby|%{_bindir}/ruby|' $file
chmod 755 $file
done
# Remove backup files
find %{buildroot}/%{geminstdir} -type f -name "*~" -delete
-# Delete zero-length files
-find %{buildroot}/%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
+# Don't delete zero-length files (bug 496480)
+#find %{buildroot}/%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
# Fix anything executable that does not have a shebang
for file in `find %{buildroot}/%{geminstdir} -type f -perm /a+x`; do
[ -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 644 $file
done
+# For sure...
+find %{buildroot} -name \*.gem | xargs chmod 0644
+
# Find files with a shebang that do not have executable permissions
for file in `find %{buildroot}/%{geminstdir} -type f ! -perm /a+x -name "*.rb"`; do
[ ! -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 755 $file
@@ -105,9 +108,18 @@ rm -rf %{buildroot}
%changelog
+* Fri Jul 31 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp>
+- Restore some changes
+
* Sun Jul 26 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 2.3.3-1
- New upstream version
+* Wed Jul 24 2009 Scott Seago <sseago@redhat.com> - 2.3.2-3
+- Remove the 'delete zero length files' bit, as some of these are needed.
+
+* Wed May 6 2009 David Lutterkort <lutter@redhat.com> - 2.3.2-2
+- Fix replacement of shebang lines; broke scripts/generate (bz 496480)
+
* Mon Mar 16 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 2.3.2-1
- New upstream version