summaryrefslogtreecommitdiffstats
path: root/rubygem-paperclip.spec
diff options
context:
space:
mode:
authorKen Dreyer <ktdreyer@ktdreyer.com>2014-02-05 17:22:02 -0700
committerKen Dreyer <ktdreyer@ktdreyer.com>2014-02-05 17:22:28 -0700
commit33d27b0f24ea5d3530c17e8adaaf8b0eb4723ede (patch)
treefd0e429b462cdc1e55b701df065c1a1b57304d32 /rubygem-paperclip.spec
parent2b122538d6e187ddccfa6a9edd4b8c34824d2269 (diff)
downloadrubygem-paperclip-33d27b0f24ea5d3530c17e8adaaf8b0eb4723ede.tar.gz
rubygem-paperclip-33d27b0f24ea5d3530c17e8adaaf8b0eb4723ede.tar.xz
rubygem-paperclip-33d27b0f24ea5d3530c17e8adaaf8b0eb4723ede.zip
Update to 4.0.0
Diffstat (limited to 'rubygem-paperclip.spec')
-rw-r--r--rubygem-paperclip.spec36
1 files changed, 22 insertions, 14 deletions
diff --git a/rubygem-paperclip.spec b/rubygem-paperclip.spec
index e167e0c..c9c0882 100644
--- a/rubygem-paperclip.spec
+++ b/rubygem-paperclip.spec
@@ -1,7 +1,7 @@
%global gem_name paperclip
Name: rubygem-%{gem_name}
-Version: 3.5.0
+Version: 4.0.0
Release: 1%{?dist}
Summary: File attachments as attributes for ActiveRecord
Group: Development/Languages
@@ -12,12 +12,12 @@ Requires: ruby(release)
Requires: ruby(rubygems)
Requires: rubygem(activemodel) >= 3.0.0
Requires: rubygem(activesupport) >= 3.0.0
-Requires: rubygem(cocaine) => 0.5.0
+Requires: rubygem(cocaine) => 0.5.3
Requires: rubygem(cocaine) < 0.6
Requires: rubygem(mime-types)
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
-BuildRequires: ruby >= 1.9.2
+BuildRequires: ruby
BuildRequires: ImageMagick
# Minitest and deps
BuildRequires: rubygem(minitest)
@@ -59,6 +59,12 @@ gem unpack %{SOURCE0}
gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
+# Remove developer-only files.
+for f in .gitignore .travis.yml Gemfile Rakefile; do
+ rm $f
+ sed -i "s|\"$f\",||g" %{gem_name}.gemspec
+done
+
# Remove dependency on pry gem.
find test -name '*.rb' -print0 | xargs -0 \
sed -e "/require 'pry'/d" -i
@@ -67,8 +73,6 @@ find test -name '*.rb' -print0 | xargs -0 \
# Create the gem as gem install only works on a gem file
gem build %{gem_name}.gemspec
-# %%gem_install compiles any C extensions and installs the gem into ./%gem_dir
-# by default, so that we can move it into the buildroot in %%install
%gem_install
# Remove extra gemspec file
@@ -90,7 +94,7 @@ popd
%files
%dir %{gem_instdir}
%doc %{gem_instdir}/LICENSE
-%exclude %{gem_instdir}/.*
+%doc %{gem_instdir}/README.md
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
@@ -100,19 +104,23 @@ popd
%doc %{gem_instdir}/Appraisals
%doc %{gem_instdir}/CONTRIBUTING.md
%doc %{gem_instdir}/NEWS
-%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/RUNNING_TESTS.md
%doc %{gem_instdir}/UPGRADING
-%{gem_instdir}/Gemfile
-%{gem_instdir}/Rakefile
-%{gem_instdir}/cucumber
-%{gem_instdir}/gemfiles
-%{gem_instdir}/features
-%{gem_instdir}/shoulda_macros
-%{gem_instdir}/test
+%exclude %{gem_instdir}/cucumber
+%exclude %{gem_instdir}/gemfiles
+%exclude %{gem_instdir}/features
+%exclude %{gem_instdir}/shoulda_macros
+%exclude %{gem_instdir}/test
%changelog
+* Thu Feb 06 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 4.0.0-1
+- Update to 4.0.0
+- Move README to main package
+- Remove Gemfile, Rakefile and dot files during %%prep
+- %%exclude more unnecessary files
+- Drop ruby version comparison
+
* Sat Jul 27 2013 ktdreyer@ktdreyer.com - 3.5.0-1
- Update to 3.5.0
- Move LICENSE to main package