summaryrefslogtreecommitdiffstats
path: root/rubygem-paperclip.spec
diff options
context:
space:
mode:
authorKen Dreyer <ktdreyer@ktdreyer.com>2013-07-27 19:51:00 -0600
committerKen Dreyer <ktdreyer@ktdreyer.com>2013-07-28 00:44:05 -0600
commit2b122538d6e187ddccfa6a9edd4b8c34824d2269 (patch)
treec7e6506fc6c2fe261cce3c1aa5da83a001e44dfe /rubygem-paperclip.spec
parenteb952ddedadbc78d456bb8be90180ff35ea52815 (diff)
downloadrubygem-paperclip-2b122538d6e187ddccfa6a9edd4b8c34824d2269.tar.gz
rubygem-paperclip-2b122538d6e187ddccfa6a9edd4b8c34824d2269.tar.xz
rubygem-paperclip-2b122538d6e187ddccfa6a9edd4b8c34824d2269.zip
update to 3.5.0
Diffstat (limited to 'rubygem-paperclip.spec')
-rw-r--r--rubygem-paperclip.spec62
1 files changed, 32 insertions, 30 deletions
diff --git a/rubygem-paperclip.spec b/rubygem-paperclip.spec
index b57eb20..e167e0c 100644
--- a/rubygem-paperclip.spec
+++ b/rubygem-paperclip.spec
@@ -1,26 +1,23 @@
-# Generated from paperclip-3.1.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name paperclip
-%global rubyabi 1.9.1
-Summary: File attachments as attributes for ActiveRecord
Name: rubygem-%{gem_name}
-Version: 3.1.4
+Version: 3.5.0
Release: 1%{?dist}
+Summary: File attachments as attributes for ActiveRecord
Group: Development/Languages
License: MIT
URL: https://github.com/thoughtbot/paperclip
-Source0: http://rubygems.org/gems/%{gem_name}-%{version}.gem
-Patch0: rubygem-paperclip-3.1.4-skip-broken-fog-tests.patch
-Requires: ruby(abi) = %{rubyabi}
-Requires: ruby(rubygems)
-Requires: rubygem(activerecord) >= 3.0.0
+Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
+Requires: ruby(release)
+Requires: ruby(rubygems)
Requires: rubygem(activemodel) >= 3.0.0
Requires: rubygem(activesupport) >= 3.0.0
-Requires: rubygem(cocaine) >= 0.0.2
+Requires: rubygem(cocaine) => 0.5.0
+Requires: rubygem(cocaine) < 0.6
Requires: rubygem(mime-types)
-Requires: ImageMagick
-BuildRequires: ruby(abi) = %{rubyabi}
+BuildRequires: ruby(release)
BuildRequires: rubygems-devel
+BuildRequires: ruby >= 1.9.2
BuildRequires: ImageMagick
# Minitest and deps
BuildRequires: rubygem(minitest)
@@ -56,28 +53,30 @@ BuildArch: noarch
Documentation for %{name}
%prep
-%setup -q -c -T
-mkdir -p .%{gem_dir}
-gem install --local --install-dir .%{gem_dir} \
- --force %{SOURCE0}
+gem unpack %{SOURCE0}
-# Skip two tests that fail with old versions of rubygem(fog).
-# https://github.com/thoughtbot/paperclip/pull/837
-pushd .%{gem_instdir}
-%patch0 -p1
-popd
+%setup -q -D -T -n %{gem_name}-%{version}
-# Remove developer files
-rm -rf .%{gem_instdir}/.gitignore
-rm -rf .%{gem_instdir}/.travis.yml
-# Remove extra gemspec file
-rm -rf .%{gem_instdir}/%{gem_name}.gemspec
+gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
+
+# Remove dependency on pry gem.
+find test -name '*.rb' -print0 | xargs -0 \
+ sed -e "/require 'pry'/d" -i
%build
+# Create the gem as gem install only works on a gem file
+gem build %{gem_name}.gemspec
+
+# %%gem_install compiles any C extensions and installs the gem into ./%gem_dir
+# by default, so that we can move it into the buildroot in %%install
+%gem_install
+
+# Remove extra gemspec file
+rm .%{gem_instdir}/%{gem_name}.gemspec
%install
mkdir -p %{buildroot}%{gem_dir}
-cp -a .%{gem_dir}/* \
+cp -pa .%{gem_dir}/* \
%{buildroot}%{gem_dir}/
%check
@@ -88,9 +87,10 @@ pushd .%{gem_instdir}
#cucumber features/*.feature
popd
-
%files
%dir %{gem_instdir}
+%doc %{gem_instdir}/LICENSE
+%exclude %{gem_instdir}/.*
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
@@ -99,13 +99,11 @@ popd
%doc %{gem_docdir}
%doc %{gem_instdir}/Appraisals
%doc %{gem_instdir}/CONTRIBUTING.md
-%doc %{gem_instdir}/LICENSE
%doc %{gem_instdir}/NEWS
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/RUNNING_TESTS.md
%doc %{gem_instdir}/UPGRADING
%{gem_instdir}/Gemfile
-%{gem_instdir}/Gemfile.lock
%{gem_instdir}/Rakefile
%{gem_instdir}/cucumber
%{gem_instdir}/gemfiles
@@ -115,5 +113,9 @@ popd
%changelog
+* Sat Jul 27 2013 ktdreyer@ktdreyer.com - 3.5.0-1
+- Update to 3.5.0
+- Move LICENSE to main package
+
* Fri Aug 03 2012 Ken Dreyer <ktdreyer@ktdreyer.com> - 3.1.4-1
- Initial package, created by gem2rpm 0.8.1