summaryrefslogtreecommitdiffstats
path: root/rubygem-mysql2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-mysql2.spec')
-rw-r--r--rubygem-mysql2.spec22
1 files changed, 21 insertions, 1 deletions
diff --git a/rubygem-mysql2.spec b/rubygem-mysql2.spec
index 9880b00..963e17f 100644
--- a/rubygem-mysql2.spec
+++ b/rubygem-mysql2.spec
@@ -1,11 +1,15 @@
# Generated from mysql2-0.3.11.gem by gem2rpm -*- rpm-spec -*-
%global gem_name mysql2
+%if 0%{?el6}
+%global rubyabi 1.8
+%else
%global rubyabi 1.9.1
+%endif
Summary: A simple, fast Mysql library for Ruby, binding to libmysql
Name: rubygem-%{gem_name}
Version: 0.3.11
-Release: 1%{?dist}
+Release: 2%{?dist}
Group: Development/Languages
License: MIT
URL: http://github.com/brianmario/mysql2
@@ -14,13 +18,26 @@ Requires: ruby(abi) = %{rubyabi}
Requires: ruby(rubygems)
BuildRequires: ruby(abi) = %{rubyabi}
BuildRequires: ruby-devel
+%if 0%{?fedora}
BuildRequires: rubygems-devel
+%else
+BuildRequires: ruby(rubygems)
+%endif
BuildRequires: mysql-devel
BuildRequires: mysql-server
BuildRequires: rubygem(eventmachine)
BuildRequires: rubygem(rspec)
Provides: rubygem(%{gem_name}) = %{version}
+# macros for RHEL6 compatibility:
+%{!?gem_dir: %global gem_dir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)}
+%{!?gem_instdir: %global gem_instdir %{gem_dir}/gems/%{gem_name}-%{version}}
+%{!?gem_libdir: %global gem_libdir %{gem_instdir}/lib}
+%{!?gem_cache: %global gem_cache %{gem_dir}/cache/%{gem_name}-%{version}.gem}
+%{!?gem_spec: %global gem_spec %{gem_dir}/specifications/%{gem_name}-%{version}.gemspec}
+%{!?gem_docdir: %global gem_docdir %{gem_dir}/doc/%{gem_name}-%{version}}
+%{!?gem_extdir: %global gem_extdir %{_libdir}/gems/exts/%{gem_name}-%{version}}
+
%description
The Mysql2 gem is meant to serve the extremely common use-case of
connecting, querying and iterating on results. Some database libraries out
@@ -101,5 +118,8 @@ popd
%{gem_instdir}/tasks
%changelog
+* Thu Feb 14 2013 Ken Dreyer <ktdreyer@ktdreyer.com> - 0.3.11-2
+- RHEL 6 compatibility
+
* Sat Aug 04 2012 Ken Dreyer <ktdreyer@ktdreyer.com> - 0.3.11-1
- Initial package, created by gem2rpm 0.8.1