summaryrefslogtreecommitdiffstats
path: root/rubygem-activesupport.spec
diff options
context:
space:
mode:
authorMohammed Morsi <mmorsi@redhat.com>2010-08-24 16:40:30 -0400
committerMohammed Morsi <mmorsi@redhat.com>2010-08-24 16:40:30 -0400
commit1b66c60a4eff41e4e72b7d167c156b4778e04f29 (patch)
tree224362799910b4c30beccb9cf8cd53d25f027cfe /rubygem-activesupport.spec
parent1c15bb776fb511b06e2a929b93f99f300dced81c (diff)
downloadrubygem-activesupport-1b66c60a4eff41e4e72b7d167c156b4778e04f29.tar.gz
rubygem-activesupport-1b66c60a4eff41e4e72b7d167c156b4778e04f29.tar.xz
rubygem-activesupport-1b66c60a4eff41e4e72b7d167c156b4778e04f29.zip
updated to activesupport 2.3.8
Diffstat (limited to 'rubygem-activesupport.spec')
-rw-r--r--rubygem-activesupport.spec36
1 files changed, 35 insertions, 1 deletions
diff --git a/rubygem-activesupport.spec b/rubygem-activesupport.spec
index 78d0827..75def99 100644
--- a/rubygem-activesupport.spec
+++ b/rubygem-activesupport.spec
@@ -9,16 +9,33 @@
Summary: Support and utility classes used by the Rails framework
Name: rubygem-%{gemname}
Epoch: 1
-Version: 2.3.5
+Version: 2.3.8
Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
+
Source0: http://gems.rubyforge.org/gems/%{gemname}-%{version}.gem
+
+# For some reason the activesupport doesn't ship with the upstream Rakefile
+Source1: http://github.com/rails/rails/raw/2-3-stable/activesupport/Rakefile
+
+# Also the activesupport gem doesn't ship with the test suite like the other
+# Rails rpms, you may check it out like so
+# git clone http://github.com/rails/rails.git -b 2-3-stable
+# cd rails/activesupport/
+# git reset --hard 9da7ff8842e5e6407872 # revisions after this correspond to
+# # rails 2.3.9 and break test suite
+# # when run against stock 2.3.8 gem
+# tar czvf activesupport-23-tests.tgz test/
+Source2: activesupport-23-tests.tgz
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: rubygems
Requires: ruby(abi) = %{rubyabi}
BuildRequires: rubygems
+BuildRequires(check): rubygem(rake)
+BuildRequires(check): rubygem(mocha)
BuildArch: noarch
Provides: rubygem(%{gemname}) = %{version}
@@ -36,6 +53,12 @@ mkdir -p %{buildroot}%{gemdir}
gem install --local --install-dir %{buildroot}%{gemdir} \
--force --rdoc %{SOURCE0}
+# move the rakefile in place
+cp %{SOURCE1} %{buildroot}%{geminstdir}
+
+# move the tests into place
+tar xzvf %{SOURCE2} -C %{buildroot}%{geminstdir}
+
# Remove bad shebangs
for file in %{buildroot}%{geminstdir}/lib/active_support/vendor/builder-2.1.2/builder.rb \
%{buildroot}%{geminstdir}/lib/active_support/vendor/builder-2.1.2/blankslate.rb \
@@ -56,18 +79,29 @@ done
%clean
rm -rf %{buildroot}
+%check
+pushd %{buildroot}%{geminstdir}
+rake test
+
%files
%defattr(-, root, root, -)
%dir %{geminstdir}
%doc %{geminstdir}/CHANGELOG
+%{geminstdir}/Rakefile
%{geminstdir}/lib
%doc %{geminstdir}/README
%doc %{gemdir}/doc/%{gemname}-%{version}
%{gemdir}/cache/%{gemname}-%{version}.gem
%{gemdir}/specifications/%{gemname}-%{version}.gemspec
+%{geminstdir}/test
%changelog
+* Wed Aug 04 2010 Mohammed Morsi <mmorsi@redhat.com> - 1:2.3.8-1
+- Update to 2.3.8
+- Added check section with rubygem-mocha dependency
+- Added upsteam Rakefile and test suite to run tests
+
* Thu Jan 28 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1:2.3.5-1
- Update to 2.3.5