summaryrefslogtreecommitdiffstats
path: root/rubygem-activerecord.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-activerecord.spec')
-rw-r--r--rubygem-activerecord.spec21
1 files changed, 17 insertions, 4 deletions
diff --git a/rubygem-activerecord.spec b/rubygem-activerecord.spec
index fcdfed5..8493b5f 100644
--- a/rubygem-activerecord.spec
+++ b/rubygem-activerecord.spec
@@ -6,8 +6,8 @@
Summary: Implements the ActiveRecord pattern for ORM
Name: rubygem-%{gemname}
-Version: 2.2.2
-Release: 2%{?dist}
+Version: 2.3.2
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
@@ -35,11 +35,21 @@ mkdir -p %{buildroot}%{gemdir}
gem install --local --install-dir %{buildroot}%{gemdir} \
--force --rdoc %{SOURCE0}
+# Remove backup files
+find %{buildroot}/%{geminstdir} -type f -name "*~" -delete
+
# Delete zero-length files
find %{buildroot}/%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
-find %{buildroot}/%{geminstdir}/test/ -name "*.rb" -exec chmod 644 {} \;
-find %{buildroot}/%{geminstdir}/lib/active_record/ -name "*.rb" -exec chmod 644 {} \;
+# Fix anything executable that does not have a shebang
+for file in `find %{buildroot}/%{geminstdir} -type f -perm /a+x`; do
+ [ -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 644 $file
+done
+
+# Find files with a shebang that do not have executable permissions
+for file in `find %{buildroot}/%{geminstdir} -type f ! -perm /a+x -name "*.rb"`; do
+ [ ! -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 755 $file
+done
%clean
rm -rf %{buildroot}
@@ -61,6 +71,9 @@ rm -rf %{buildroot}
%{gemdir}/specifications/%{gemname}-%{version}.gemspec
%changelog
+* Mon Mar 16 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 2.3.2-1
+- New upstream version
+
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild