summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec35
1 files changed, 13 insertions, 22 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index befe029..0e709ae 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -1,15 +1,16 @@
# Generated from actionpack-1.13.5.gem by gem2rpm -*- rpm-spec -*-
-%define gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
-%define gemname actionpack
-%define geminstdir %{gemdir}/gems/%{gemname}-%{version}
+%global gemname actionpack
-%define rubyabi 1.8
+%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
+%global geminstdir %{gemdir}/gems/%{gemname}-%{version}
+
+%global rubyabi 1.8
Summary: Web-flow and rendering framework putting the VC in MVC
Name: rubygem-%{gemname}
Epoch: 1
-Version: 3.0.5
-Release: 3%{?dist}
+Version: 3.0.9
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
@@ -22,9 +23,9 @@ Source1: http://github.com/rails/rails/raw/v%{version}/%{gemname}/Rakefile
# You may check it out like so
# git clone http://github.com/rails/rails.git
# cd rails/actionpack/
-# git checkout v3.0.5
-# tar czvf actionpack-tests.tgz test/
-Source2: actionpack-tests.tgz
+# git checkout v3.0.9
+# tar czvf actionpack-3.0.9-tests.tgz test/
+Source2: actionpack-3.0.9-tests.tgz
Patch0: rubygem-actionpack-enable-test.patch
@@ -36,15 +37,6 @@ Patch1: actionpack-rakefile-fix.patch
# dependency on a file in the greater rails proj
Patch2: actionpack-tests-fix.patch
-Patch3: actionpack-downgrade-dependencies.patch
-
-# CVE-2011-2197
-# http://weblog.rubyonrails.org/2011/6/8/potential-xss-vulnerability-in-ruby-on-rails-applications
-# FIXES: https://gist.github.com/b2ceb626fc2bcdfe497f
-# https://github.com/rails/rails/commit/c6503f48bd13c696fcc81f2a4a87b8cd7c009657
-# https://github.com/rails/rails/commit/2e757bc298cef715e5c56945161bbd84f2610729
-Patch4: cve-2011-2197-actionpack-fix.patch
-
Requires: rubygems
Requires: rubygem(activesupport) = %{version}
Requires: rubygem(activemodel) = %{version}
@@ -102,7 +94,6 @@ pushd .%{geminstdir}
%patch0 -p0
%patch1 -p0
%patch2 -p0
-%patch4 -p0
# create missing symlink
pushd test/fixtures/layout_tests/layouts/
@@ -111,9 +102,6 @@ popd
popd
-pushd .%{gemdir}
-%patch3 -p0
-
# Remove backup files
# No! these are needed for rake test
# find ./%{geminstdir} -type f -name "*~" -delete
@@ -173,6 +161,9 @@ rake test --trace
%changelog
+* Mon Jul 04 2011 Vít Ondruch <vondruch@redhat.com> - 1:3.0.9-1
+- Update to ActionPack 3.0.9
+
* Thu Jun 16 2011 Mo Morsi <mmorsi@redhat.com> - 1:3.0.5-3
- Include fix for CVE-2011-2197