summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec36
1 files changed, 27 insertions, 9 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index f3870f6..2882f9d 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -4,23 +4,28 @@
%define gemname actionpack
%define geminstdir %{gemdir}/gems/%{gemname}-%{version}
+%define rubyabi 1.8
+
Summary: Web-flow and rendering framework putting the VC in MVC
Name: rubygem-%{gemname}
-Version: 2.3.3
+Version: 2.3.4
Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
Source0: http://gems.rubyforge.org/gems/%{gemname}-%{version}.gem
+Patch0: rubygem-actionpack-2.3.4-enable-test.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: rubygems
Requires: rubygem(activesupport) = %{version}
Requires: rubygem(rack) >= 1.0.0
+Requires: ruby(abi) = %{rubyabi}
BuildRequires: rubygems
BuildRequires(check): rubygem(rake)
BuildRequires(check): rubygem(rack) >= 1.0.0
BuildRequires(check): rubygem(mocha) >= 0.9.7
BuildRequires(check): rubygem(activerecord) = %{version}
+BuildRequires(check): rubygem(sqlite3-ruby)
BuildArch: noarch
Provides: rubygem(%{gemname}) = %{version}
@@ -37,11 +42,23 @@ gem install --local --install-dir .%{gemdir} \
-V \
--force --rdoc %{SOURCE0}
+pushd .%{geminstdir}
+%patch0 -p0
+
+# create missing symlink
+pushd test/fixtures/layout_tests/layouts/
+ln -sf ../../symlink_parent/ symlinked
+popd
+
+popd
+
# Remove backup files
-find ./%{geminstdir} -type f -name "*~" -delete
+# No! these are needed for rake test
+# find ./%{geminstdir} -type f -name "*~" -delete
# Delete zero-length files
-find ./%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
+# No! these are also needed for rake test
+# find ./%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
# Fix anything executable that does not have a shebang
for file in `find ./%{geminstdir} -type f -perm /a+x`; do
@@ -68,15 +85,12 @@ rm -rf %{buildroot}
pushd .%{geminstdir}
# dependency loop
+# depends on actionmailer, while actionmailer has BR(check): actionpack
mv test/controller/assert_select_test.rb \
test/controller/assert_select_test.rb.skip
-# ??? need checking
-mv test/controller/caching_test.rb \
- test/controller/caching_test.rb.skip
-
-# Still 6 tests fail, please someone investigate
-rake test --trace || :
+# Now as far as I checked rake test succeeds.
+rake test --trace
%files
%defattr(-, root, root, -)
@@ -95,6 +109,10 @@ rake test --trace || :
%changelog
+* Sun Sep 20 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 2.3.4-1
+- Update to 2.3.4 (bug 520843, CVE-2009-3009)
+- Fix tests
+
* Sun Aug 2 2009 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 2.3.3-1
- 2.3.3
- Enable test (some tests fail, please someone investigate!!)