summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec32
1 files changed, 11 insertions, 21 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index d8f2661..f683d0f 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -6,8 +6,8 @@
Summary: Web-flow and rendering framework putting the VC in MVC
Name: rubygem-%{gem_name}
Epoch: 1
-Version: 3.0.11
-Release: 3%{?dist}
+Version: 3.0.13
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
@@ -20,8 +20,8 @@ Source1: http://github.com/rails/rails/raw/v%{version}/%{gem_name}/Rakefile
# You may check it out like so
# git clone http://github.com/rails/rails.git
# cd rails/actionpack/
-# git checkout v3.0.11
-# tar czvf actionpack-3.0.11-tests.tgz test/
+# git checkout v3.0.13
+# tar czvf actionpack-3.0.13-tests.tgz test/
Source2: actionpack-%{version}-tests.tgz
Patch0: rubygem-actionpack-enable-test.patch
@@ -30,20 +30,8 @@ Patch0: rubygem-actionpack-enable-test.patch
# not being present in the gem
Patch1: actionpack-rakefile-fix.patch
-# Removes code which breaks the test suite due to a
-# dependency on a file in the greater rails proj
-Patch2: actionpack-tests-fix.patch
-
Patch3: actionpack-downgrade-dependencies.patch
-# Fixes CVE-2012-1098
-# https://bugzilla.redhat.com/show_bug.cgi?id=799275
-Patch4: actionpack-CVE-2012-1098-safe-buffer-slice.patch
-
-# Fixes CVE-2012-1099
-# https://bugzilla.redhat.com/show_bug.cgi?id=799276
-Patch5: actionpack-CVE-2012-1099-select-options-XSS.patch
-
Requires: ruby(rubygems)
Requires: rubygem(activesupport) = %{version}
Requires: rubygem(activemodel) = %{version}
@@ -101,9 +89,6 @@ tar xzvf %{SOURCE2} -C .%{gem_instdir}
pushd .%{gem_instdir}
%patch0 -p0
%patch1 -p0
-%patch2 -p0
-%patch4 -p2
-%patch5 -p2
# create missing symlink
pushd test/fixtures/layout_tests/layouts/
@@ -152,6 +137,9 @@ export TMPDIR=$(pwd)/tmpdir
pushd .%{gem_instdir}
+# load_path is not available, remove its require.
+sed -i '1,2d' test/abstract_unit.rb
+
# dependency loop
# depends on actionmailer, while actionmailer has BR(check): actionpack
mv test/controller/assert_select_test.rb \
@@ -161,7 +149,6 @@ mv test/controller/assert_select_test.rb \
rake test --trace
%files
-%defattr(-, root, root, -)
%dir %{gem_instdir}
%doc %{gem_instdir}/CHANGELOG
%{gem_libdir}
@@ -170,11 +157,14 @@ rake test --trace
%doc %{gem_instdir}/README.rdoc
%doc %{gem_instdir}/test/
%doc %{gem_docdir}
-%{gem_cache}
+%exclude %{gem_cache}
%{gem_spec}
%changelog
+* Fri Jun 01 2012 Vít Ondruch <vondruch@redhat.com> - 1:3.0.13-1
+- Updated to the ActionPack 3.0.13.
+
* Fri Mar 16 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 1:3.0.11-3
- The CVE patches names now contain the CVE id.