summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec78
1 files changed, 40 insertions, 38 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index 77b3dc8..61e6799 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -1,30 +1,27 @@
# Generated from actionpack-1.13.5.gem by gem2rpm -*- rpm-spec -*-
-%global gemname actionpack
+%global gem_name actionpack
-%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
-%global geminstdir %{gemdir}/gems/%{gemname}-%{version}
-
-%global rubyabi 1.8
+%global rubyabi 1.9.1
Summary: Web-flow and rendering framework putting the VC in MVC
-Name: rubygem-%{gemname}
+Name: rubygem-%{gem_name}
Epoch: 1
-Version: 3.0.10
-Release: 2%{?dist}
+Version: 3.0.11
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
Source0: http://rubygems.org/downloads/actionpack-%{version}.gem
# The actionpack gem doesn't ship with the upstream Rakefile
-Source1: http://github.com/rails/rails/raw/v%{version}/%{gemname}/Rakefile
+Source1: http://github.com/rails/rails/raw/v%{version}/%{gem_name}/Rakefile
# Also the actionpack gem doesn't ship with the test suite.
# You may check it out like so
# git clone http://github.com/rails/rails.git
# cd rails/actionpack/
-# git checkout v3.0.10
-# tar czvf actionpack-3.0.10-tests.tgz test/
+# git checkout v3.0.11
+# tar czvf actionpack-3.0.11-tests.tgz test/
Source2: actionpack-%{version}-tests.tgz
Patch0: rubygem-actionpack-enable-test.patch
@@ -39,7 +36,7 @@ Patch2: actionpack-tests-fix.patch
Patch3: actionpack-downgrade-dependencies.patch
-Requires: rubygems
+Requires: ruby(rubygems)
Requires: rubygem(activesupport) = %{version}
Requires: rubygem(activemodel) = %{version}
Requires: rubygem(builder) = 2.1.2
@@ -51,7 +48,7 @@ Requires: rubygem(tzinfo) >= 0.3.23
Requires: rubygem(erubis) >= 2.6.5
Requires: rubygem(erubis) < 2.7.0
Requires: ruby(abi) = %{rubyabi}
-BuildRequires: rubygems
+BuildRequires: rubygems-devel
BuildRequires: rubygem(rake)
BuildRequires: rubygem(mocha) >= 0.9.7
BuildRequires: rubygem(activesupport) = %{version}
@@ -66,8 +63,9 @@ BuildRequires: rubygem(rack-mount)
BuildRequires: rubygem(tzinfo) >= 0.3.23
BuildRequires: rubygem(erubis) >= 2.6.5
BuildRequires: rubygem(erubis) < 2.7.0
+BuildRequires: rubygem(minitest)
BuildArch: noarch
-Provides: rubygem(%{gemname}) = %{version}
+Provides: rubygem(%{gem_name}) = %{version}
%description
Eases web-request routing, handling, and response as a half-way front,
@@ -77,22 +75,22 @@ unit/integration testing that doesn't require a browser.
%prep
%setup -q -c -T
-mkdir -p .%{gemdir}
-gem install --local --install-dir .%{gemdir} \
+mkdir -p .%{gem_dir}
+gem install --local --install-dir .%{gem_dir} \
-V \
--force --rdoc %{SOURCE0}
# forcely modify gemspec for rack dependency
sed -i -e '/rack/s|~>|>=|' \
- ./%{gemdir}/specifications/*gemspec
+ ./%{gem_dir}/specifications/*gemspec
# move the Rakefile in place
-cp %{SOURCE1} .%{geminstdir}
+cp %{SOURCE1} .%{gem_instdir}
# move the tests into place
-tar xzvf %{SOURCE2} -C .%{geminstdir}
+tar xzvf %{SOURCE2} -C .%{gem_instdir}
-pushd .%{geminstdir}
+pushd .%{gem_instdir}
%patch0 -p0
%patch1 -p0
%patch2 -p0
@@ -104,33 +102,33 @@ popd
popd
-pushd .%{gemdir}
+pushd .%{gem_dir}
%patch3 -p0
popd
# Remove backup files
# No! these are needed for rake test
-# find ./%{geminstdir} -type f -name "*~" -delete
+# find ./%{gem_instdir} -type f -name "*~" -delete
# Delete zero-length files
# No! these are also needed for rake test
-# find ./%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
+# find ./%{gem_instdir} -type f -size 0c -exec rm -rvf {} \;
# Fix anything executable that does not have a shebang
-for file in `find ./%{geminstdir} -type f -perm /a+x`; do
+for file in `find ./%{gem_instdir} -type f -perm /a+x`; do
[ -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 644 $file
done
# Find files with a shebang that do not have executable permissions
-for file in `find ./%{geminstdir} -type f ! -perm /a+x -name "*.rb"`; do
+for file in `find ./%{gem_instdir} -type f ! -perm /a+x -name "*.rb"`; do
[ ! -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 755 $file
done
%build
%install
-mkdir -p %{buildroot}%{gemdir}
-cp -a .%{gemdir}/* %{buildroot}%{gemdir}
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* %{buildroot}%{gem_dir}
%clean
@@ -142,7 +140,7 @@ rm -rf ./tmpdir
mkdir ./tmpdir
export TMPDIR=$(pwd)/tmpdir
-pushd .%{geminstdir}
+pushd .%{gem_instdir}
# dependency loop
# depends on actionmailer, while actionmailer has BR(check): actionpack
@@ -154,19 +152,23 @@ rake test --trace
%files
%defattr(-, root, root, -)
-%dir %{geminstdir}
-%doc %{geminstdir}/CHANGELOG
-%{geminstdir}/lib
-%doc %{geminstdir}/MIT-LICENSE
-%{geminstdir}/Rakefile
-%doc %{geminstdir}/README.rdoc
-%doc %{geminstdir}/test/
-%doc %{gemdir}/doc/%{gemname}-%{version}
-%{gemdir}/cache/%{gemname}-%{version}.gem
-%{gemdir}/specifications/%{gemname}-%{version}.gemspec
+%dir %{gem_instdir}
+%doc %{gem_instdir}/CHANGELOG
+%{gem_libdir}
+%doc %{gem_instdir}/MIT-LICENSE
+%{gem_instdir}/Rakefile
+%doc %{gem_instdir}/README.rdoc
+%doc %{gem_instdir}/test/
+%doc %{gem_docdir}
+%{gem_cache}
+%{gem_spec}
%changelog
+* Tue Jan 31 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 1:3.0.11-1
+- Rebuilt for Ruby 1.9.3.
+- Updated to ActionPack 3.0.11.
+
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.0.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild