summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
authorJeroen van Meeuwen <kanarip@fedoraproject.org>2009-03-16 11:07:24 +0000
committerJeroen van Meeuwen <kanarip@fedoraproject.org>2009-03-16 11:07:24 +0000
commita923fd142a57d11f2e80c0857ba37f42953714b0 (patch)
treecbcb9e656c33bcf8e91b6ae5d7ad9063e5aac429 /rubygem-actionpack.spec
parent6196891b3db44dc0e3480bd6171d349b205fb669 (diff)
downloadrubygem-actionpack-a923fd142a57d11f2e80c0857ba37f42953714b0.tar.gz
rubygem-actionpack-a923fd142a57d11f2e80c0857ba37f42953714b0.tar.xz
rubygem-actionpack-a923fd142a57d11f2e80c0857ba37f42953714b0.zip
2.3.2-1
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec23
1 files changed, 20 insertions, 3 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index 5f49112..cb0b03e 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -6,8 +6,8 @@
Summary: Web-flow and rendering framework putting the VC in MVC
Name: rubygem-%{gemname}
-Version: 2.2.2
-Release: 2%{?dist}
+Version: 2.3.2
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
@@ -35,7 +35,21 @@ mkdir -p %{buildroot}%{gemdir}
gem install --local --install-dir %{buildroot}%{gemdir} \
--force --rdoc %{SOURCE0}
-sed -i -e 1d %{buildroot}%{geminstdir}/lib/action_controller/session/drb_server.rb
+# Remove backup files
+find %{buildroot}/%{geminstdir} -type f -name "*~" -delete
+
+# Delete zero-length files
+find %{buildroot}/%{geminstdir} -type f -size 0c -exec rm -rvf {} \;
+
+# Fix anything executable that does not have a shebang
+for file in `find %{buildroot}/%{geminstdir} -type f -perm /a+x`; do
+ [ -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 644 $file
+done
+
+# Find files with a shebang that do not have executable permissions
+for file in `find %{buildroot}/%{geminstdir} -type f ! -perm /a+x -name "*.rb"`; do
+ [ ! -z "`head -n 1 $file | grep \"^#!/\"`" ] && chmod -v 755 $file
+done
%clean
rm -rf %{buildroot}
@@ -57,6 +71,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 16 2009 Jeroen van Meeuwen <j.van.meeuwen@ogd.nl> - 2.3.2-1
+- New upstream version
+
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild