summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
authorDavid Lutterkort <lutter@fedoraproject.org>2007-11-29 23:13:48 +0000
committerDavid Lutterkort <lutter@fedoraproject.org>2007-11-29 23:13:48 +0000
commit6f11774f6dd24ce115f608588fcd5b82fa956bca (patch)
treed211079cf86c39e9bec654b043ca591a6242f0f6 /rubygem-actionpack.spec
parentd31e9239e2f7f9d6add82a64d70f9a22ff50f0a8 (diff)
downloadrubygem-actionpack-6f11774f6dd24ce115f608588fcd5b82fa956bca.tar.gz
rubygem-actionpack-6f11774f6dd24ce115f608588fcd5b82fa956bca.tar.xz
rubygem-actionpack-6f11774f6dd24ce115f608588fcd5b82fa956bca.zip
New package
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
new file mode 100644
index 0000000..d9e4711
--- /dev/null
+++ b/rubygem-actionpack.spec
@@ -0,0 +1,76 @@
+# Generated from actionpack-1.13.5.gem by gem2rpm -*- rpm-spec -*-
+%define ruby_sitelib %(ruby -rrbconfig -e "puts Config::CONFIG['sitelibdir']")
+%define gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
+%define gemname actionpack
+%define geminstdir %{gemdir}/gems/%{gemname}-%{version}
+
+Summary: Web-flow and rendering framework putting the VC in MVC
+Name: rubygem-%{gemname}
+Version: 1.13.6
+Release: 1%{?dist}
+Group: Development/Languages
+License: MIT
+URL: http://www.rubyonrails.org
+Source0: http://gems.rubyforge.org/gems/%{gemname}-%{version}.gem
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Requires: rubygems
+Requires: rubygem(activesupport) = 1.4.4
+BuildRequires: rubygems
+BuildArch: noarch
+Provides: rubygem(%{gemname}) = %{version}
+
+%description
+Eases web-request routing, handling, and response as a half-way front,
+half-way page controller. Implemented with specific emphasis on enabling easy
+unit/integration testing that doesn't require a browser.
+
+
+%prep
+
+%build
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{gemdir}
+gem install --local --install-dir %{buildroot}%{gemdir} \
+ --force --rdoc %{SOURCE0}
+
+# Cleanup some upstream packaging oddities
+mv %{buildroot}%{geminstdir}/examples/.htaccess %{buildroot}%{geminstdir}/examples/htaccess
+
+for f in address_book_controller.rbx blog_controller.cgi debate_controller.cgi \
+ address_book_controller.cgi benchmark_with_ar.fcgi \
+ address_book_controller.fcgi ; do
+ sed -i -e '1c\#! /usr/bin/ruby' %{buildroot}%{geminstdir}/examples/$f
+done
+sed -i -e 1d %{buildroot}%{geminstdir}/lib/action_controller/session/drb_server.rb
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%defattr(-, root, root, -)
+%doc %{geminstdir}/CHANGELOG
+%doc %{geminstdir}/examples
+%dir %{geminstdir}
+%{geminstdir}/install.rb
+%{geminstdir}/lib
+%doc %{geminstdir}/MIT-LICENSE
+%{geminstdir}/Rakefile
+%doc %{geminstdir}/README
+%doc %{geminstdir}/RUNNING_UNIT_TESTS
+%{geminstdir}/test/
+%doc %{gemdir}/doc/%{gemname}-%{version}
+%{gemdir}/cache/%{gemname}-%{version}.gem
+%{gemdir}/specifications/%{gemname}-%{version}.gemspec
+
+
+%changelog
+* Thu Nov 29 2007 David Lutterkort <dlutter@redhat.com> - 1.13.6-1
+- New version
+
+* Tue Nov 14 2007 David Lutterkort <dlutter@redhat.com> - 1.13.5-2
+- Fix buildroot; mark docs in geminstdir cleanly
+
+* Tue Oct 30 2007 David Lutterkort <dlutter@redhat.com> - 1.13.5-1
+- Initial package