summaryrefslogtreecommitdiffstats
path: root/rubygem-actionpack.spec
diff options
context:
space:
mode:
authorBohuslav Kabrda <bkabrda@redhat.com>2012-07-23 10:14:54 +0200
committerBohuslav Kabrda <bkabrda@redhat.com>2012-07-23 10:14:54 +0200
commit4d535e72f25293481df9c5975cacbb123c9c0bc8 (patch)
treee31095a71d64d2bab77ab15007ad7cee3f610b83 /rubygem-actionpack.spec
parent215cae1dc164c0c8b999e0e3acef9ddcf23b4a21 (diff)
downloadrubygem-actionpack-4d535e72f25293481df9c5975cacbb123c9c0bc8.tar.gz
rubygem-actionpack-4d535e72f25293481df9c5975cacbb123c9c0bc8.tar.xz
rubygem-actionpack-4d535e72f25293481df9c5975cacbb123c9c0bc8.zip
Updated to the ActionPack 3.2.6.
- Remove Rake dependency. - Introduce -doc subpackage. - Relax sprockets dependency.
Diffstat (limited to 'rubygem-actionpack.spec')
-rw-r--r--rubygem-actionpack.spec128
1 files changed, 65 insertions, 63 deletions
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index d7a36cc..858d2bb 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -6,60 +6,64 @@
Summary: Web-flow and rendering framework putting the VC in MVC
Name: rubygem-%{gem_name}
Epoch: 1
-Version: 3.0.15
-Release: 2%{?dist}
+Version: 3.2.6
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
Source0: http://rubygems.org/downloads/actionpack-%{version}.gem
-# The actionpack gem doesn't ship with the upstream Rakefile
-Source1: http://github.com/rails/rails/raw/v%{version}/%{gem_name}/Rakefile
-
# Also the actionpack gem doesn't ship with the test suite.
# You may check it out like so
# git clone http://github.com/rails/rails.git
# cd rails/actionpack/
-# git checkout v3.0.15
-# tar czvf actionpack-3.0.15-tests.tgz test/
+# git checkout v3.2.6
+# tar czvf actionpack-3.2.6-tests.tgz test/
Source2: actionpack-%{version}-tests.tgz
Patch0: rubygem-actionpack-enable-test.patch
+Patch1: rubygem-actionpack-relax-sprockets-dependency.patch
-# Remove a task which breaks the Rakefile due to the gemspec
-# not being present in the gem
-Patch1: actionpack-rakefile-fix.patch
-
-Patch3: actionpack-downgrade-dependencies.patch
-
+# Let's keep Requires and BuildRequires sorted alphabeticaly
Requires: ruby(rubygems)
-Requires: rubygem(activesupport) = %{version}
Requires: rubygem(activemodel) = %{version}
-Requires: rubygem(builder) = 2.1.2
-Requires: rubygem(i18n) >= 0.5.0
-Requires: rubygem(rack) >= 1.0.0
-Requires: rubygem(rack-test)
-Requires: rubygem(rack-mount)
-Requires: rubygem(tzinfo) >= 0.3.23
-Requires: rubygem(erubis) >= 2.6.5
-Requires: rubygem(erubis) < 2.7.0
+Requires: rubygem(activesupport) = %{version}
+Requires: rubygem(builder) >= 3.0.0
+Requires: rubygem(builder) < 3.1
+Requires: rubygem(erubis) >= 2.7.0
+Requires: rubygem(erubis) < 2.8
+Requires: rubygem(journey) >= 1.0.4
+Requires: rubygem(journey) < 1.1
+Requires: rubygem(rack) >= 1.4.0
+Requires: rubygem(rack) < 1.5
+Requires: rubygem(rack-cache) >= 1.2
+Requires: rubygem(rack-cache) < 2
+Requires: rubygem(rack-test) >= 0.6.1
+Requires: rubygem(rack-test) < 0.7
+Requires: rubygem(sprockets) >= 2.1.3
Requires: ruby(abi) = %{rubyabi}
BuildRequires: rubygems-devel
-BuildRequires: rubygem(rake)
-BuildRequires: rubygem(mocha) >= 0.9.7
+BuildRequires: rubygem(activemodel) = %{version}
+BuildRequires: rubygem(activerecord) = %{version}
BuildRequires: rubygem(activesupport) = %{version}
-BuildRequires: rubygem(activemodel) = %{version}
-BuildRequires: rubygem(activerecord) = %{version}
-BuildRequires: rubygem(sqlite3)
-BuildRequires: rubygem(builder) = 2.1.2
-BuildRequires: rubygem(i18n) >= 0.5.0
-BuildRequires: rubygem(rack) >= 1.0.0
-BuildRequires: rubygem(rack-test)
-BuildRequires: rubygem(rack-mount)
-BuildRequires: rubygem(tzinfo) >= 0.3.23
-BuildRequires: rubygem(erubis) >= 2.6.5
-BuildRequires: rubygem(erubis) < 2.7.0
+BuildRequires: rubygem(erubis) >= 2.7.0
+BuildRequires: rubygem(erubis) < 2.8
+BuildRequires: rubygem(journey) >= 1.0.4
+BuildRequires: rubygem(journey) < 1.1
BuildRequires: rubygem(minitest)
+BuildRequires: rubygem(mocha) >= 0.9.8
+BuildRequires: rubygem(rack) >= 1.4.0
+BuildRequires: rubygem(rack) < 1.5
+BuildRequires: rubygem(rack-cache) >= 1.2
+BuildRequires: rubygem(rack-cache) < 2
+BuildRequires: rubygem(rack-test) >= 0.6.1
+BuildRequires: rubygem(rack-test) < 0.7
+BuildRequires: rubygem(sprockets) >= 2.1.3
+BuildRequires: rubygem(sqlite3)
+BuildRequires: rubygem(therubyracer)
+BuildRequires: rubygem(tzinfo) >= 0.3.29
+BuildRequires: rubygem(tzinfo) < 0.4
+BuildRequires: rubygem(uglifier)
BuildArch: noarch
Provides: rubygem(%{gem_name}) = %{version}
@@ -68,27 +72,26 @@ Eases web-request routing, handling, and response as a half-way front,
half-way page controller. Implemented with specific emphasis on enabling easy
unit/integration testing that doesn't require a browser.
+%package doc
+Summary: Documentation for %{name}
+Group: Documentation
+Requires:%{name} = %{version}-%{release}
+
+%description doc
+Documentation for %{name}
%prep
%setup -q -c -T
mkdir -p .%{gem_dir}
gem install --local --install-dir .%{gem_dir} \
-V \
- --force --rdoc %{SOURCE0}
-
-# forcely modify gemspec for rack dependency
-sed -i -e '/rack/s|~>|>=|' \
- ./%{gem_dir}/specifications/*gemspec
-
-# move the Rakefile in place
-cp %{SOURCE1} .%{gem_instdir}
+ --force --no-rdoc %{SOURCE0}
# move the tests into place
tar xzvf %{SOURCE2} -C .%{gem_instdir}
pushd .%{gem_instdir}
%patch0 -p0
-%patch1 -p0
# create missing symlink
pushd test/fixtures/layout_tests/layouts/
@@ -98,7 +101,7 @@ popd
popd
pushd .%{gem_dir}
-%patch3 -p0
+%patch1 -p0
popd
# Remove backup files
@@ -130,43 +133,42 @@ cp -a .%{gem_dir}/* %{buildroot}%{gem_dir}
rm -rf %{buildroot}
%check
-# Don't pollute /tmp, it won't be cleaned up after build
-rm -rf ./tmpdir
-mkdir ./tmpdir
-export TMPDIR=$(pwd)/tmpdir
-
pushd .%{gem_instdir}
# load_path is not available, remove its require.
sed -i '1,2d' test/abstract_unit.rb
-# While work locally, this test fails on Koji. Can't find a reason why. It
-# might be related to different rubygem-mock version used by Fedora then Rails
-# specifies.
-sed -i '375,383 s|^|#|' test/dispatch/request_test.rb
-
# dependency loop
# depends on actionmailer, while actionmailer has BR(check): actionpack
mv test/controller/assert_select_test.rb \
test/controller/assert_select_test.rb.skip
-# Now as far as I checked rake test succeeds.
-rake test --trace
+ruby -w -I.:lib:test -e 'Dir.glob("test/{abstract,controller,dispatch,template}/**/*_test.rb").each {|t| require t}'
+# activerecord tests must be run separately, otherwise we get superclass mismatch error
+# due to test classes that have same names in activerecord and other tests
+ruby -w -I.:lib:test -e 'Dir.glob("test/activerecord/**/*_test.rb").each {|t| require t}'
+popd
%files
%dir %{gem_instdir}
-%doc %{gem_instdir}/CHANGELOG
-%{gem_libdir}
%doc %{gem_instdir}/MIT-LICENSE
-%{gem_instdir}/Rakefile
-%doc %{gem_instdir}/README.rdoc
-%doc %{gem_instdir}/test/
-%doc %{gem_docdir}
+%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
+%files doc
+%doc %{gem_docdir}
+%doc %{gem_instdir}/CHANGELOG.md
+%doc %{gem_instdir}/README.rdoc
+%{gem_instdir}/test/
%changelog
+* Thu Jul 19 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 1:3.2.6-1
+- Updated to the ActionPack 3.2.6.
+- Remove Rake dependency.
+- Introduce -doc subpackage.
+- Relax sprockets dependency.
+
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.0.15-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild