summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVít Ondruch <vondruch@redhat.com>2011-03-28 16:21:27 +0200
committerVít Ondruch <vondruch@redhat.com>2011-03-28 16:21:27 +0200
commitc4b905298bfbbe4ae473bf2b798b2e5dfe11bf3b (patch)
tree139ce73fd55e3a221a5111c0e1fe3465c384fc7c
parent3c401a3a0a1005bb3e5337ddd0dcf586aa6d0015 (diff)
downloadrubygem-actionpack-c4b905298bfbbe4ae473bf2b798b2e5dfe11bf3b.zip
rubygem-actionpack-c4b905298bfbbe4ae473bf2b798b2e5dfe11bf3b.tar.gz
rubygem-actionpack-c4b905298bfbbe4ae473bf2b798b2e5dfe11bf3b.tar.xz
Updated to ActionPack 3.0.5.
-rw-r--r--Rakefile6
-rw-r--r--actionpack-add-rack-mount-deps.patch16
-rw-r--r--actionpack-downgrade-dependencies.patch31
-rw-r--r--rubygem-actionpack.spec20
4 files changed, 37 insertions, 36 deletions
diff --git a/Rakefile b/Rakefile
index 30e81b6..d67c6f2 100644
--- a/Rakefile
+++ b/Rakefile
@@ -33,6 +33,12 @@ Rake::TestTask.new(:test_active_record_integration) do |t|
t.test_files = Dir.glob("test/activerecord/*_test.rb")
end
+spec = eval(File.read('actionpack.gemspec'))
+
+Rake::GemPackageTask.new(spec) do |p|
+ p.gem_spec = spec
+end
+
desc "Release to gemcutter"
task :release => :package do
require 'rake/gemcutter'
diff --git a/actionpack-add-rack-mount-deps.patch b/actionpack-add-rack-mount-deps.patch
index 0ff26e8..a35c178 100644
--- a/actionpack-add-rack-mount-deps.patch
+++ b/actionpack-add-rack-mount-deps.patch
@@ -1,29 +1,29 @@
---- specifications/actionpack-3.0.3.gemspec.orig 2011-02-01 17:55:54.677899001 -0500
-+++ specifications/actionpack-3.0.3.gemspec 2011-02-01 17:56:04.943899003 -0500
-@@ -29,6 +29,8 @@ Gem::Specification.new do |s|
+--- specifications/actionpack-3.0.5.gemspec.orig 2011-02-01 17:55:54.677899001 -0500
++++ specifications/actionpack-3.0.5.gemspec 2011-02-01 17:56:04.943899003 -0500
+@@ -28,6 +28,8 @@
s.add_runtime_dependency(%q<rack>, [">= 1.1.0"])
s.add_runtime_dependency(%q<rack-test>, [">= 0.5.4"])
s.add_runtime_dependency(%q<rack-mount>, [">= 0.6.13"])
+ s.add_runtime_dependency(%q<multimap>, [">= 1.1.2"])
+ s.add_runtime_dependency(%q<regin>, [">= 0.3.7"])
s.add_runtime_dependency(%q<tzinfo>, ["~> 0.3.23"])
- s.add_runtime_dependency(%q<erubis>, ["~> 2.6.5"])
+ s.add_runtime_dependency(%q<erubis>, ["~> 2.6.6"])
else
-@@ -39,6 +41,8 @@ Gem::Specification.new do |s|
+@@ -38,6 +40,8 @@
s.add_dependency(%q<rack>, [">= 1.1.0"])
s.add_dependency(%q<rack-test>, [">= 0.5.4"])
s.add_dependency(%q<rack-mount>, [">= 0.6.13"])
+ s.add_dependency(%q<multimap>, [">= 1.1.2"])
+ s.add_dependency(%q<regin>, [">= 0.3.7"])
s.add_dependency(%q<tzinfo>, ["~> 0.3.23"])
- s.add_dependency(%q<erubis>, ["~> 2.6.5"])
+ s.add_dependency(%q<erubis>, ["~> 2.6.6"])
end
-@@ -50,6 +54,8 @@ Gem::Specification.new do |s|
+@@ -49,6 +53,8 @@
s.add_dependency(%q<rack>, [">= 1.1.0"])
s.add_dependency(%q<rack-test>, [">= 0.5.4"])
s.add_dependency(%q<rack-mount>, [">= 0.6.13"])
+ s.add_dependency(%q<multimap>, [">= 1.1.2"])
+ s.add_dependency(%q<regin>, [">= 0.3.7"])
s.add_dependency(%q<tzinfo>, ["~> 0.3.23"])
- s.add_dependency(%q<erubis>, ["~> 2.6.5"])
+ s.add_dependency(%q<erubis>, ["~> 2.6.6"])
end
diff --git a/actionpack-downgrade-dependencies.patch b/actionpack-downgrade-dependencies.patch
index 3d383f9..0a81d76 100644
--- a/actionpack-downgrade-dependencies.patch
+++ b/actionpack-downgrade-dependencies.patch
@@ -1,43 +1,40 @@
---- specifications/actionpack-3.0.3.gemspec.orig 2011-01-18 16:24:30.469405214 -0500
-+++ specifications/actionpack-3.0.3.gemspec 2011-01-18 16:26:01.445405000 -0500
-@@ -26,31 +26,31 @@ Gem::Specification.new do |s|
- s.add_runtime_dependency(%q<activemodel>, ["= 3.0.3"])
+--- specifications/actionpack-3.0.5.gemspec.orig 2011-01-18 16:24:30.469405214 -0500
++++ specifications/actionpack-3.0.5.gemspec 2011-01-18 16:26:01.445405000 -0500
+@@ -25,31 +25,31 @@ Gem::Specification.new do |s|
+ s.add_runtime_dependency(%q<activemodel>, ["= 3.0.5"])
s.add_runtime_dependency(%q<builder>, ["~> 2.1.2"])
s.add_runtime_dependency(%q<i18n>, ["~> 0.4"])
- s.add_runtime_dependency(%q<rack>, [">= 1.2.1"])
-- s.add_runtime_dependency(%q<rack-test>, [">= 0.5.6"])
+- s.add_runtime_dependency(%q<rack-test>, [">= 0.5.7"])
+ s.add_runtime_dependency(%q<rack>, [">= 1.1.0"])
+ s.add_runtime_dependency(%q<rack-test>, [">= 0.5.4"])
s.add_runtime_dependency(%q<rack-mount>, [">= 0.6.13"])
s.add_runtime_dependency(%q<tzinfo>, ["~> 0.3.23"])
-- s.add_runtime_dependency(%q<erubis>, ["~> 2.6.6"])
-+ s.add_runtime_dependency(%q<erubis>, ["~> 2.6.5"])
+ s.add_runtime_dependency(%q<erubis>, ["~> 2.6.6"])
else
- s.add_dependency(%q<activesupport>, ["= 3.0.3"])
- s.add_dependency(%q<activemodel>, ["= 3.0.3"])
+ s.add_dependency(%q<activesupport>, ["= 3.0.5"])
+ s.add_dependency(%q<activemodel>, ["= 3.0.5"])
s.add_dependency(%q<builder>, ["~> 2.1.2"])
s.add_dependency(%q<i18n>, ["~> 0.4"])
- s.add_dependency(%q<rack>, [">= 1.2.1"])
-- s.add_dependency(%q<rack-test>, [">= 0.5.6"])
+- s.add_dependency(%q<rack-test>, [">= 0.5.7"])
+ s.add_dependency(%q<rack>, [">= 1.1.0"])
+ s.add_dependency(%q<rack-test>, [">= 0.5.4"])
s.add_dependency(%q<rack-mount>, [">= 0.6.13"])
s.add_dependency(%q<tzinfo>, ["~> 0.3.23"])
-- s.add_dependency(%q<erubis>, ["~> 2.6.6"])
-+ s.add_dependency(%q<erubis>, ["~> 2.6.5"])
+ s.add_dependency(%q<erubis>, ["~> 2.6.6"])
end
else
- s.add_dependency(%q<activesupport>, ["= 3.0.3"])
- s.add_dependency(%q<activemodel>, ["= 3.0.3"])
+ s.add_dependency(%q<activesupport>, ["= 3.0.5"])
+ s.add_dependency(%q<activemodel>, ["= 3.0.5"])
s.add_dependency(%q<builder>, ["~> 2.1.2"])
s.add_dependency(%q<i18n>, ["~> 0.4"])
- s.add_dependency(%q<rack>, [">= 1.2.1"])
-- s.add_dependency(%q<rack-test>, [">= 0.5.6"])
+- s.add_dependency(%q<rack-test>, [">= 0.5.7"])
+ s.add_dependency(%q<rack>, [">= 1.1.0"])
+ s.add_dependency(%q<rack-test>, [">= 0.5.4"])
s.add_dependency(%q<rack-mount>, [">= 0.6.13"])
s.add_dependency(%q<tzinfo>, ["~> 0.3.23"])
-- s.add_dependency(%q<erubis>, ["~> 2.6.6"])
-+ s.add_dependency(%q<erubis>, ["~> 2.6.5"])
+ s.add_dependency(%q<erubis>, ["~> 2.6.6"])
end
end
diff --git a/rubygem-actionpack.spec b/rubygem-actionpack.spec
index e3ed902..00766a1 100644
--- a/rubygem-actionpack.spec
+++ b/rubygem-actionpack.spec
@@ -8,8 +8,8 @@
Summary: Web-flow and rendering framework putting the VC in MVC
Name: rubygem-%{gemname}
Epoch: 1
-Version: 3.0.3
-Release: 4%{?dist}
+Version: 3.0.5
+Release: 1%{?dist}
Group: Development/Languages
License: MIT
URL: http://www.rubyonrails.org
@@ -22,7 +22,7 @@ Source1: http://github.com/rails/rails/raw/v%{version}/%{gemname}/Rakefile
# You may check it out like so
# git clone http://github.com/rails/rails.git
# cd rails/actionpack/
-# git checkout v3.0.3
+# git checkout v3.0.5
# tar czvf actionpack-tests.tgz test/
Source2: actionpack-tests.tgz
@@ -40,16 +40,11 @@ Patch3: actionpack-downgrade-dependencies.patch
Patch4: actionpack-add-rack-mount-deps.patch
-#
-# Please someone fix the following Patch2!! (mtasaka)
-#
-#Patch2: rubygem-actionpack-2.3.5-rack-compat.patch
-
Requires: rubygems
Requires: rubygem(activesupport) = %{version}
Requires: rubygem(activemodel) = %{version}
Requires: rubygem(builder) = 2.1.2
-Requires: rubygem(i18n) = 0.4.2
+Requires: rubygem(i18n) >= 0.5.0
Requires: rubygem(rack) >= 1.0.0
Requires: rubygem(rack-test)
Requires: rubygem(rack-mount)
@@ -65,7 +60,7 @@ BuildRequires: rubygem(activemodel) = %{version}
BuildRequires: rubygem(activerecord) = %{version}
BuildRequires: rubygem(sqlite3)
BuildRequires: rubygem(builder) = 2.1.2
-BuildRequires: rubygem(i18n) = 0.4.2
+BuildRequires: rubygem(i18n) >= 0.5.0
BuildRequires: rubygem(rack) >= 1.0.0
BuildRequires: rubygem(rack-test)
BuildRequires: rubygem(rack-mount)
@@ -100,7 +95,7 @@ tar xzvf %{SOURCE2} -C .%{geminstdir}
pushd .%{geminstdir}
%patch0 -p0
-#%patch1 -p0
+%patch1 -p0
%patch2 -p0
# create missing symlink
@@ -173,6 +168,9 @@ rake test --trace
%changelog
+* Fri Mar 25 2011 Vít Ondruch <vondruch@redhat.com> - 1:3.0.5-1
+- Updated to ActionPack 3.0.5
+
* Wed Feb 16 2011 Vít Ondruch <vondruch@redhat.com> - 1:3.0.3-4
- Relaxed erubis dependency
- Fixed build compatibility with RubyGems 1.5