summaryrefslogtreecommitdiffstats
path: root/python-workdays.spec
diff options
context:
space:
mode:
authorKen Dreyer <ktdreyer@ktdreyer.com>2017-04-07 11:48:12 -0600
committerKen Dreyer <ktdreyer@ktdreyer.com>2017-04-07 11:48:12 -0600
commit2c8cf10716dd2e178c0dbdc0e412a49ee2612715 (patch)
tree9edc3502c7dad874606ed1579df0cafba2d6234b /python-workdays.spec
downloadpython-workdays-master.tar.gz
python-workdays-master.tar.xz
python-workdays-master.zip
initial import (v1.4)HEADmaster
Diffstat (limited to 'python-workdays.spec')
-rw-r--r--python-workdays.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-workdays.spec b/python-workdays.spec
new file mode 100644
index 0000000..64f8fd9
--- /dev/null
+++ b/python-workdays.spec
@@ -0,0 +1,73 @@
+%if 0%{?fedora}
+%global with_python3 1
+%endif
+
+%define srcname workdays
+
+Name: python-%{srcname}
+Version: 1.4
+Release: 1%{?dist}
+Summary: Workday date utility functions to extend python's datetime
+License: BSD
+URL: http://github.com/ogt/workdays
+Source0: https://pypi.python.org/packages/source/w/%{srcname}/%{srcname}-%{version}.tar.gz
+
+
+BuildRequires: python-devel >= 2.6
+BuildRequires: python-setuptools
+%if 0%{?with_python3}
+BuildRequires: python3-devel
+%endif # with_python3
+
+BuildArch: noarch
+
+%description
+Extend python datetime with excel-like workday addition/subtraction
+
+
+%package -n python2-%{srcname}
+Summary: %{summary}
+%{?python_provide:%python_provide python2-%{srcname}}
+
+%description -n python2-%{srcname}
+Extend python datetime with excel-like workday addition/subtraction
+
+%if 0%{?with_python3}
+%package -n python3-%{srcname}
+Summary: %{summary}
+Requires: python3
+%{?python_provide:%python_provide python3-%{srcname}}
+
+%description -n python3-%{srcname}
+Extend python datetime with excel-like workday addition/subtraction
+%endif # with_python3
+
+%prep
+%autosetup -n %{srcname}-%{version} -p1
+
+%build
+%{py2_build}
+
+%if 0%{?with_python3}
+%{py3_build}
+%endif # with_python3
+
+%install
+%py2_install
+
+%if 0%{?with_python3}
+%py3_install
+%endif # with_python3
+
+%files -n python2-%{srcname}
+%{python_sitelib}/*
+
+%if 0%{?with_python3}
+%files -n python3-%{srcname}
+%{python3_sitelib}/*
+%endif # with_python3
+
+
+%changelog
+* Fri Apr 07 2017 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.4-1
+- initial package