summaryrefslogtreecommitdiffstats
path: root/python-testscenarios.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-testscenarios.spec')
-rw-r--r--python-testscenarios.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/python-testscenarios.spec b/python-testscenarios.spec
new file mode 100644
index 0000000..3e0b433
--- /dev/null
+++ b/python-testscenarios.spec
@@ -0,0 +1,49 @@
+%global pypi_name testscenarios
+
+Name: python-%{pypi_name}
+Version: 0.4
+Release: 2%{?dist}
+Summary: Testscenarios, a pyunit extension for dependency injection
+
+License: ASL 2.0 and BSD
+URL: https://launchpad.net/testscenarios
+Source0: http://pypi.python.org/packages/source/t/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
+BuildArch: noarch
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-testtools
+
+%description
+testscenarios provides clean dependency injection for python unittest style
+tests. This can be used for interface testing (testing many implementations via
+a single test suite) or for classic dependency injection (provide tests with
+dependencies externally to the test code itself, allowing easy testing in
+different situations).
+
+%prep
+%setup -q -n %{pypi_name}-%{version}
+# Remove bundled egg-info
+rm -rf %{pypi_name}.egg-info
+
+
+%build
+%{__python} setup.py build
+
+
+%install
+%{__python} setup.py install --skip-build --root %{buildroot}
+
+
+%files
+%doc Apache-2.0 BSD GOALS HACKING NEWS README doc/
+%{python_sitelib}/%{pypi_name}
+%{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
+
+%changelog
+* Tue May 21 2013 Matthias Runge <mrunge@redhat.com> - 0.4-2
+- correct License: ASL 2.0 and BSD
+- include doc files
+
+* Fri May 17 2013 Matthias Runge <mrunge@redhat.com> - 0.4-1
+- Initial package.