summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBill Maxwell <bill.t.maxwell@gmail.com>2014-02-03 22:30:11 -0700
committerBill Maxwell <bill.t.maxwell@gmail.com>2014-02-06 21:26:32 -0700
commit98579924ef3a0ce0688f9a0f8c81d238f42996aa (patch)
tree3e3e27783c6cd1d4a3fe1e85488c4f2ad03d73c1 /setup.py
parenta32288a57335fd50ea09c4fa603f7d74ef99a5ff (diff)
downloadpython-jenkins-job-builder-98579924ef3a0ce0688f9a0f8c81d238f42996aa.tar.gz
python-jenkins-job-builder-98579924ef3a0ce0688f9a0f8c81d238f42996aa.tar.xz
python-jenkins-job-builder-98579924ef3a0ce0688f9a0f8c81d238f42996aa.zip
added logstash plugin support and fixed test typo
Added new test cases in wrappers fixtures. Updated setup.py to include the new wrapper entry point. Added the logstash plugin to the wrapper module. made the default the localhost for host. Added an if around the use redis bool. If Redis parameters are not defined, use an empty dict to use all defaults. Change-Id: Iee950a7d05a56d3a45b5f93ccd77306b37662d25
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4a7c542b..897ae597 100644
--- a/setup.py
+++ b/setup.py
@@ -202,6 +202,7 @@ setuptools.setup(
'inject-passwords=jenkins_jobs.modules.wrappers:inject_passwords',
'jclouds=jenkins_jobs.modules.wrappers:jclouds',
'locks=jenkins_jobs.modules.wrappers:locks',
+ 'logstash=jenkins_jobs.modules.wrappers:logstash',
'mask-passwords=jenkins_jobs.modules.wrappers:mask_passwords',
'pathignore=jenkins_jobs.modules.wrappers:pathignore',
'port-allocator=jenkins_jobs.modules.wrappers:port_allocator',