summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2016-12-09 18:26:58 -0600
committerMonty Taylor <mordred@inaugust.com>2016-12-10 09:42:57 -0600
commit503fd8dcd413a6c90293cd04844834c94d44f03b (patch)
treececdc36da39b52d0a4b72ed4487e1d7936b2e609 /setup.py
parentdd8ba49a7c5531ab40a87a77b610b3f5a65a3675 (diff)
downloadpython-jenkins-job-builder-503fd8dcd413a6c90293cd04844834c94d44f03b.tar.gz
python-jenkins-job-builder-503fd8dcd413a6c90293cd04844834c94d44f03b.tar.xz
python-jenkins-job-builder-503fd8dcd413a6c90293cd04844834c94d44f03b.zip
Sync requirements with openstack/requirements
This is not necessary - jenkins-job-builder does not follow the requirements sync process. That said - these are likely all safe bets for being solid versions of these dependencies - and some of them were kinda stale. Change-Id: Id1941ff4c9736100f9bdd5508ec3c0377e51fdbe
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 20 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index a5af70f0..782bb21f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,19 +1,29 @@
-# Copyright 2012 Hewlett-Packard Development Company, L.P.
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
-# Licensed under the Apache License, Version 2.0 (the "License"); you may
-# not use this file except in compliance with the License. You may obtain
-# a copy of the License at
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-# License for the specific language governing permissions and limitations
-# under the License.
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
- setup_requires=['pbr'],
+ setup_requires=['pbr>=1.8'],
pbr=True)