summaryrefslogtreecommitdiffstats
path: root/python-execnet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-execnet.spec')
-rw-r--r--python-execnet.spec5
1 files changed, 3 insertions, 2 deletions
diff --git a/python-execnet.spec b/python-execnet.spec
index 4fa2cba..313bd60 100644
--- a/python-execnet.spec
+++ b/python-execnet.spec
@@ -105,10 +105,11 @@ rm doc/_build/html/.buildinfo
%check
-PYTHONPATH=$(pwd) py.test-%{python_version} --report=skipped
+PYTHONPATH=$(pwd) py.test-%{python_version} -r s
%if 0%{?with_python3}
pushd %{py3dir}
-PYTHONPATH=$(pwd) py.test-%{python3_version} --report=skipped
+# see http://bugs.python.org/issue12591
+PYTHONPATH=$(pwd) py.test-%{python3_version} -r s -k-test_subprocess_interaction
popd
%endif # with_python3