summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-08 14:58:57 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-08 14:58:57 +0000
commita1c0e839460d9f8495f21b4e627ed98fbe21ee8e (patch)
treeb2811f50081057be8a5eb688192a72c02622c68e /configure.in
parent9b7574685332ff22c546dbe8afabca7e96aac2de (diff)
downloadruby-a1c0e839460d9f8495f21b4e627ed98fbe21ee8e.tar.gz
ruby-a1c0e839460d9f8495f21b4e627ed98fbe21ee8e.tar.xz
ruby-a1c0e839460d9f8495f21b4e627ed98fbe21ee8e.zip
* configure.in (RDOCTARGET): new macro. if you want to install
rdoc documentation, you need to run configure with --enable-install-doc. git-svn-id: http://svn.ruby-lang.org/repos/ruby/trunk@5419 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c51fd57b1..3c07c4e40 100644
--- a/configure.in
+++ b/configure.in
@@ -1223,6 +1223,16 @@ fi
XLDFLAGS="$XLDFLAGS -L."
AC_SUBST(ARCHFILE)
+dnl build rdoc index if requested
+RDOCTARGET=""
+AC_ARG_ENABLE(install-doc,
+ [ --enable-install-doc build and install rdoc indexes during install ],
+ [install_doc=$enableval], [install_doc=no])
+if test "$install_doc" != no; then
+ RDOCTARGET="install-doc"
+fi
+AC_SUBST(RDOCTARGET)
+
case "$target_os" in
netbsd*)
CFLAGS="$CFLAGS -pipe"