summaryrefslogtreecommitdiffstats
path: root/libaec/libaec.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libaec/libaec.spec')
-rw-r--r--libaec/libaec.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/libaec/libaec.spec b/libaec/libaec.spec
index 7d913b0..08c4e50 100644
--- a/libaec/libaec.spec
+++ b/libaec/libaec.spec
@@ -6,8 +6,10 @@ License: BSD
Url: https://gitlab.dkrz.de/k202009/libaec
Source: https://gitlab.dkrz.de/k202009/libaec/uploads/631e85bcf877c2dcaca9b2e6d6526339/libaec-1.0.0.tar.gz
+BuildRequires: cmake
+
%description
-Libaec provides fast loss-less compression of 1 up to 32 bit wide
+Libaec provides fast lossless compression of 1 up to 32 bit wide
signed or unsigned integers (samples). The library achieves best
results for low entropy data as often encountered in space imaging
instrument data or numerical model output from weather or climate
@@ -32,16 +34,19 @@ Devel files and static library for libaec (Adaptive Entropy Coding library).
%setup -q
%build
-%configure --disable-static
-sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
-sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+mkdir build
+pushd build
+%cmake ..
%make_build
+#make %{?_smp_mflags} CFLAGS="%{optflags}"
+popd
%install
-%make_install
+%make_install -C build
+[ %{_lib} = lib ] || mv $RPM_BUILD_ROOT/%{_prefix}/{lib,%{_lib}}
%check
-make check
+make -C build test
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig