summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..3927621
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(top_srcdir)/include
+LDADD = $(top_srcdir)/src/.libs/libcgroup.la
+
+# compile the tests, but do not install them
+noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test
+
+libcgrouptest01_SOURCES=libcgrouptest01.c test_functions.c libcgrouptest.h
+libcg_ba_SOURCES=libcg_ba.cpp
+setuid_SOURCES=setuid.c
+pathtest_SOURCES=pathtest.c
+walk_test_SOURCES=walk_test.c
+
+EXTRA_DIST = pathtest.sh runlibcgrouptest.sh
+
+TESTS = runlibcgrouptest.sh