summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c30393a
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,11 @@
+SUBDIRS = . daemon pam tools
+
+# generate parse.h from parse.y
+AM_YFLAGS = -d
+
+INCLUDES = -I$(top_srcdir)/include
+lib_LTLIBRARIES = libcgroup.la
+libcgroup_la_SOURCES = parse.y lex.l api.c config.c libcgroup-internal.h libcgroup.map wrapper.c
+libcgroup_la_LIBADD = -lpthread
+libcgroup_la_LDFLAGS = -Wl,--version-script,libcgroup.map -version-number $(LIBRARY_VERSION)
+