summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 0bc7938..46cd26e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1 +1,9 @@
EXTRA_DIST = init.d/cgconfig.in init.d/cgred.in
+
+INITSCRIPTDIR=$(DESTDIR)/etc/init.d
+install-exec-hook:
+ mkdir -p $(INITSCRIPTDIR)
+ cp init.d/cgconfig init.d/cgred $(INITSCRIPTDIR)
+
+uninstall-hook:
+ rm -f $(INITSCRIPTDIR)/cgconfig $(INITSCRIPTDIR)/cgred