summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8271cd1..04afe31 100644
--- a/configure.in
+++ b/configure.in
@@ -41,11 +41,16 @@ AC_ARG_ENABLE([debug],
AC_PROG_CXX
AC_PROG_CC
AC_PROG_YACC
-if test "$YACC" != byacc; then
- YACC="$SHELL $missing_dir/missing byacc"
- AC_SUBST(YACC, "byacc")
+if test "$YACC" = yacc; then
+ AC_CHECK_PROG([REALLY_YACC], [yacc], [yacc])
+ if test "$REALLY_YACC" = ""; then
+ AC_MSG_ERROR([This program cannot be built unless a version of yacc is installed.])
+ fi
fi
AM_PROG_LEX
+if test "$LEX" != flex; then
+ AC_MSG_ERROR([This program cannot be built unless flex is installed.])
+fi
AC_PROG_LIBTOOL
# Checks for header files.