summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDhaval Giani <dhaval@linux.vnet.ibm.com>2009-04-22 15:30:20 +0530
committerDhaval Giani <dhaval@linux.vnet.ibm.com>2009-04-22 15:46:54 +0530
commite672700698bf8078ed8cc277855760d6d030dae5 (patch)
tree1f706d0aa7e341aa325e8cf44c43f7ad70dfffdd /tests/Makefile.am
parent9414f3be0c3f191fdea212ecc3157af5e70a45de (diff)
downloadlibcg-e672700698bf8078ed8cc277855760d6d030dae5.tar.gz
libcg-e672700698bf8078ed8cc277855760d6d030dae5.tar.xz
libcg-e672700698bf8078ed8cc277855760d6d030dae5.zip
libcgroup: Add test cases for new get_task API
This is the test case for the new API. This test takes one argument, the group name. Sample run on my system with this test case returns, [dhaval@gondor tests]$ ../libtool --mode=execute ./walk_task a Printing the details of groups a Pid is 6092 Pid is 11315 Pid is 11318 Pid is 11319 Pid is 11324 Pid is 13234 [dhaval@gondor tests]$ Signed-off-by: Dhaval Giani <dhaval@linux.vnet.ibm.com> Acked-by: Balbir Singh <balbir@linux.vnet.ibm.com> Acked-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5999389..41aebd3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,7 @@ INCLUDES = -I$(top_srcdir)/include
LDADD = $(top_srcdir)/src/.libs/libcgroup.la
# compile the tests, but do not install them
-noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats
+noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats walk_task
libcgrouptest01_SOURCES=libcgrouptest01.c test_functions.c libcgrouptest.h
libcg_ba_SOURCES=libcg_ba.cpp
@@ -10,6 +10,7 @@ setuid_SOURCES=setuid.c
pathtest_SOURCES=pathtest.c
walk_test_SOURCES=walk_test.c
read_stats_SOURCES=read_stats.c
+walk_task_SOURCES=walk_task.c
EXTRA_DIST = pathtest.sh runlibcgrouptest.sh