summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBharata B Rao <bharata@linux.vnet.ibm.com>2009-04-01 11:29:19 +0530
committerBalbir Singh <balbir@linux.vnet.ibm.com>2009-04-01 11:29:19 +0530
commit48532a1617ed59b5aaef247eace7a5cb67a1c69c (patch)
tree34b2d9db0aa305c1398716794b8e84029b0fe72f /tests/Makefile.am
parentc47ee042c61d050b70e6b90aa50848d82e77b041 (diff)
downloadlibcg-48532a1617ed59b5aaef247eace7a5cb67a1c69c.tar.gz
libcg-48532a1617ed59b5aaef247eace7a5cb67a1c69c.tar.xz
libcg-48532a1617ed59b5aaef247eace7a5cb67a1c69c.zip
Here is the v2 of the patch which introduces APIs to read controller
specific stats. Added Makefile.am updates which I had missed in the previous post. New APIs to read controller specific statistics. This patch introduces 3 new APIs which can be used to read controller statistics iteratively. (Eg. stats from memory.stat etc) Reading of stats is initiated by cgroup_read_stats_begin() API, which returns the first stat of the requested controller in addition to returing a handle that should be used in subsequent reads. cgroup_read_stats_next() API can be used to read the remaining stats one by one. This needs the handle returned by cgroup_read_stats_begin(). cgroup_read_stats_end() API will terminate the stats reading iteration initiated by cgroup_read_stats_begin(). Changelog: v2 - Update tests/Makefile.am so that it generates appropriate rules for tests/read_stats.c in the Makefile. This is in addition to the manual updates done to the generated file tests/Makefile.in. v1 - cgroup_read_stats apis now work with relative cgroup path names instead of absolute path names. v0 - Initial post. Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com> Signed-off-by: Balbir Singh <balbir@linux.vnet.ibm.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3927621..5999389 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,13 +2,14 @@ INCLUDES = -I$(top_srcdir)/include
LDADD = $(top_srcdir)/src/.libs/libcgroup.la
# compile the tests, but do not install them
-noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test
+noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats
libcgrouptest01_SOURCES=libcgrouptest01.c test_functions.c libcgrouptest.h
libcg_ba_SOURCES=libcg_ba.cpp
setuid_SOURCES=setuid.c
pathtest_SOURCES=pathtest.c
walk_test_SOURCES=walk_test.c
+read_stats_SOURCES=read_stats.c
EXTRA_DIST = pathtest.sh runlibcgrouptest.sh