summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorIvana Hutarova Varekova <varekova@redhat.com>2010-02-08 13:31:56 +0100
committerBalbir Singh <balbir@linux.vnet.ibm.com>2010-02-10 16:43:36 +0530
commit3b85cd32d20b674325114f045cf972fb07a29079 (patch)
treef9c9f0840e5068c489a6fd1ae25a78849bbc2e62 /tests/Makefile.am
parent49f97cacb816379f629625cf23beb94729a4bbdb (diff)
downloadlibcg-3b85cd32d20b674325114f045cf972fb07a29079.tar.gz
libcg-3b85cd32d20b674325114f045cf972fb07a29079.tar.xz
libcg-3b85cd32d20b674325114f045cf972fb07a29079.zip
This is the test program for listing controller variables
This is the test program for new internal functions: int cgroup_get_value_name_count(struct cgroup_controller *controller) char *cgroup_get_value_name(struct cgroup_controller *controller, int index) The program display the variables of input controllers. Signed-off-by: Ivana Hutarova Varekova <varekova@redhat.com> Signed-off-by: Balbir Singh <balbir@linux.vnet.ibm.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b88688b..b4cb11e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,8 @@
INCLUDES = -I$(top_srcdir)/include
-LDADD = $(top_builddir)/src/.libs/libcgroup.la
+LDADD = $(top_srcdir)/src/.libs/libcgroup.la
# compile the tests, but do not install them
-noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats walk_task get_controller get_mount_point proctest get_all_controller
+noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats walk_task get_controller get_mount_point proctest get_all_controller get_variable_names
libcgrouptest01_SOURCES=libcgrouptest01.c test_functions.c libcgrouptest.h
libcg_ba_SOURCES=libcg_ba.cpp
@@ -15,6 +15,7 @@ get_controller_SOURCES=get_controller.c
get_mount_point_SOURCES=get_mount_point.c
proctest_SOURCES=proctest.c
get_all_controller_SOURCES=get_all_controller.c
+get_variable_names_SOURCES=get_variable_names.c
EXTRA_DIST = pathtest.sh runlibcgrouptest.sh