summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-12-14 09:22:36 +0100
committerDhaval Giani <dhaval@linux.vnet.ibm.com>2009-12-16 14:06:39 +0530
commitccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4 (patch)
tree3ec981181f3104bd9bc45fe18de842fe0c7d0fcf /tests/Makefile.am
parent01af1d63f5b85e7f87850cccfd3e6426d73dfb05 (diff)
downloadlibcg-ccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4.tar.gz
libcg-ccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4.tar.xz
libcg-ccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4.zip
Fix compilation outside of source directory
Configure script can be invoked outside of source directory, which allows to compile sources without spoiling the source directory with compilation artifacts (like .o files). This patch tries to fix our Makefiles to allow this to work. You can test it in current GIT checkout (in the root dir): # mkdir build; cd build; ../configure; make As result, you should see all binary files in the 'build' directory. Signed-off-by: Jan Safranek <jsafrane@redhat.com> Signed-off-by: Dhaval Giani <dhaval@linux.vnet.ibm.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1161292..b88688b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,5 @@
INCLUDES = -I$(top_srcdir)/include
-LDADD = $(top_srcdir)/src/.libs/libcgroup.la
+LDADD = $(top_builddir)/src/.libs/libcgroup.la
# compile the tests, but do not install them
noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats walk_task get_controller get_mount_point proctest get_all_controller