summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKen'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>2009-06-26 15:11:16 +0900
committerDhaval Giani <dhaval@linux.vnet.ibm.com>2009-06-29 16:53:21 +0530
commit81dda1ea06a62fb2db52af5c026ae196a2570702 (patch)
tree35aec7252b412016ee9dd3a0cd499c2f9a95241c /tests/Makefile.am
parent20bbfbdfd8777de4cc1c83a9d583ace36c6f2cd2 (diff)
downloadlibcg-81dda1ea06a62fb2db52af5c026ae196a2570702.tar.gz
libcg-81dda1ea06a62fb2db52af5c026ae196a2570702.tar.xz
libcg-81dda1ea06a62fb2db52af5c026ae196a2570702.zip
Add a new test command "proctest".
Hi, Changelog of v6: ================ * New patch. This patch adds a new test command "proctest" for testing both cgroup_get_uid_gid_from_procfs() and cgroup_get_procname_from_procfs(). # sleep 100 & [1] 28558 # ./tests/proctest $$ 28558 Pid | Process name | Uid | Gid -------+----------------------------------+-------+------- 27219 | /bin/bash | 0 | 0 28558 | /bin/sleep | 0 | 0 # The functions get a process information from /proc fs, and they are fragile because the content of /proc fs is not stable. If changing /proc fs in future, this test command will be useful for catching the change. Thanks Ken'ichi Ohmichi Signed-off-by: Ken'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp> Signed-off-by: Dhaval Giani <dhaval@linux.vnet.ibm.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b10f356..14bcdf3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,7 @@ INCLUDES = -I$(top_srcdir)/include
LDADD = $(top_srcdir)/src/.libs/libcgroup.la
# compile the tests, but do not install them
-noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats walk_task get_controller get_mount_point
+noinst_PROGRAMS = libcgrouptest01 libcg_ba setuid pathtest walk_test read_stats walk_task get_controller get_mount_point proctest
libcgrouptest01_SOURCES=libcgrouptest01.c test_functions.c libcgrouptest.h
libcg_ba_SOURCES=libcg_ba.cpp
@@ -13,6 +13,7 @@ read_stats_SOURCES=read_stats.c
walk_task_SOURCES=walk_task.c
get_controller_SOURCES=get_controller.c
get_mount_point_SOURCES=get_mount_point.c
+proctest_SOURCES=proctest.c
EXTRA_DIST = pathtest.sh runlibcgrouptest.sh