summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-12-14 09:22:36 +0100
committerDhaval Giani <dhaval@linux.vnet.ibm.com>2009-12-16 14:06:39 +0530
commitccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4 (patch)
tree3ec981181f3104bd9bc45fe18de842fe0c7d0fcf /src/Makefile.am
parent01af1d63f5b85e7f87850cccfd3e6426d73dfb05 (diff)
downloadlibcg-ccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4.tar.gz
libcg-ccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4.tar.xz
libcg-ccf9ad6d879cec4ca7a9620ebe28a53b4568b5d4.zip
Fix compilation outside of source directory
Configure script can be invoked outside of source directory, which allows to compile sources without spoiling the source directory with compilation artifacts (like .o files). This patch tries to fix our Makefiles to allow this to work. You can test it in current GIT checkout (in the root dir): # mkdir build; cd build; ../configure; make As result, you should see all binary files in the 'build' directory. Signed-off-by: Jan Safranek <jsafrane@redhat.com> Signed-off-by: Dhaval Giani <dhaval@linux.vnet.ibm.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f4106ba..652a23f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,6 +7,6 @@ INCLUDES = -I$(top_srcdir)/include
lib_LTLIBRARIES = libcgroup.la
libcgroup_la_SOURCES = parse.y lex.l api.c config.c libcgroup-internal.h libcgroup.map wrapper.c
libcgroup_la_LIBADD = -lpthread
-libcgroup_la_LDFLAGS = -Wl,--version-script,libcgroup.map \
+libcgroup_la_LDFLAGS = -Wl,--version-script,$(srcdir)/libcgroup.map \
-version-number $(LIBRARY_VERSION_MAJOR):$(LIBRARY_VERSION_MINOR):$(LIBRARY_VERSION_RELEASE)