summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDhaval Giani <dhaval@linux.vnet.ibm.com>2009-02-16 08:45:54 +0000
committerDhaval Giani <dhaval@linux.vnet.ibm.com>2009-02-16 08:45:54 +0000
commit0c8f9d54c6d49bba08767fb9a1593c5a4b85445b (patch)
treec27e0801842411cac20c95c776fca1045c0dfe9c /configure.in
parent492bd6ac5f9c703f1687ff8d56bb4a0d014557b8 (diff)
downloadlibcg-0c8f9d54c6d49bba08767fb9a1593c5a4b85445b.tar.gz
libcg-0c8f9d54c6d49bba08767fb9a1593c5a4b85445b.tar.xz
libcg-0c8f9d54c6d49bba08767fb9a1593c5a4b85445b.zip
libcgroup: Add configure option to enable debug output
From: Jan Safranek <jsafrane@redhat.com> There is new configure script option, which defines CGROUP_DEBUG. Usage: ./configure --enable-debug Signed-off-by: Jan Safranek <jsafrane@redhat.com> Signed-off-by: Dhaval Giani <dhaval@linux.vnet.ibm.com> git-svn-id: https://libcg.svn.sourceforge.net/svnroot/libcg/trunk@326 4f4bb910-9a46-0410-90c8-c897d4f1cd53
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 788877b..48c51e8 100644
--- a/configure.in
+++ b/configure.in
@@ -18,6 +18,14 @@ AC_INIT([control groups library and utilities], 0.32.2,
AC_CONFIG_SRCDIR([wrapper.c])
AC_CONFIG_HEADER([config.h])
+# Process command line options
+AC_ARG_ENABLE([debug],
+ [AC_HELP_STRING([--enable-debug],
+ [enable extra debugging output [default=no]])],
+ [AC_DEFINE([CGROUP_DEBUG], [],
+ [Define to enable extra debugging output.])],
+ [])
+
# Checks for programs.
AC_PROG_CXX
AC_PROG_CC