summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-03-13 15:16:20 +0100
committerJan Safranek <jsafrane@redhat.com>2009-03-26 09:36:41 +0100
commit07ff50e0856fecd937fb6a5ce87871f19f20f004 (patch)
treed35b0a391af1bc48d0b9ec7e9cd7f138a2126f58 /configure.in
parentb64a3c84e46550df4455ef4e46ec5d3b36486d65 (diff)
downloadlibcg-07ff50e0856fecd937fb6a5ce87871f19f20f004.tar.gz
libcg-07ff50e0856fecd937fb6a5ce87871f19f20f004.tar.xz
libcg-07ff50e0856fecd937fb6a5ce87871f19f20f004.zip
Add automake makefiles
Add automake makefiles and prepare everything to run, but don't actually run the automake - it would generate lot of noise, where my manual changes would get lots. Signed-off-by: Jan Safranek <jsafrane@redhat.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 25 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index d9ae295..19d6254 100644
--- a/configure.in
+++ b/configure.in
@@ -13,9 +13,17 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
#
AC_PREREQ(2.61)
+
+# In following section update all occurences of version, including soname
AC_INIT([control groups library and utilities], 0.34,
[http://sourceforge.net/tracker/?group_id=218421&atid=1043649])
-AC_CONFIG_SRCDIR([wrapper.c])
+AM_INIT_AUTOMAKE(libcgroup, 0.34)
+# set library version (X:Y:Z gets transfromed to libcgroup.so.X.Y.Z,
+# soname is libcgroup.so.X
+AC_SUBST(LIBRARY_VERSION, 1:0:34)
+
+
+AC_CONFIG_SRCDIR([src])
AC_CONFIG_HEADER([config.h])
# Process command line options
@@ -34,10 +42,10 @@ if test "$YACC" != byacc; then
YACC="$SHELL $missing_dir/missing byacc"
AC_SUBST(YACC, "byacc")
fi
-AC_PROG_LEX
+AM_PROG_LEX
+AC_PROG_LIBTOOL
# Checks for libraries.
-# FIXME: Replace `main' with a function in `-lcgroup':
AC_CHECK_LIB([cgroup], [cgroup_create_cgroup])
# Checks for header files.
@@ -61,8 +69,19 @@ AC_FUNC_REALLOC
AC_FUNC_STAT
AC_CHECK_FUNCS([getmntent hasmntopt memset mkdir rmdir strdup])
-AC_CONFIG_FILES([Makefile])
-AC_CONFIG_FILES([libcgroup.spec:libcgroup.spec.in])
-AC_CONFIG_FILES([mktarball:mktarball.in])
+AC_CONFIG_FILES([Makefile
+ tests/Makefile
+ src/Makefile
+ src/daemon/Makefile
+ src/tools/Makefile
+ src/pam/Makefile
+ scripts/Makefile
+ samples/Makefile
+ include/Makefile
+ doc/Makefile
+ doc/man/Makefile
+ dist/Makefile])
+AC_CONFIG_FILES([dist/libcgroup.spec:dist/libcgroup.spec.in])
CFLAGS="$CFLAGS -Wall"
AC_OUTPUT
+