summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-06-30 14:29:19 +0200
committerDhaval Giani <dhaval@linux.vnet.ibm.com>2009-07-01 20:34:50 +0530
commita9816059ccbf1d49e86998fb495204d2d7a47309 (patch)
tree3c4029222e0eba04445e5ad533a0a80b027c8f61 /configure.in
parent94a0ad95bc19f181beadef7cf7c4dade556eba7f (diff)
downloadlibcg-a9816059ccbf1d49e86998fb495204d2d7a47309.tar.gz
libcg-a9816059ccbf1d49e86998fb495204d2d7a47309.tar.xz
libcg-a9816059ccbf1d49e86998fb495204d2d7a47309.zip
Configure the location of cgrulesengd socket
This patch allows users to configure location of cgrulesengd socket before compilation: ./configure --enable-cgred-socket=/var/run/cgred.socket In addition, /var/run/cgred.socket is now default location of the socket - this sounds LSB compliant to me. Feel free to suggest better one. Signed-off-by: Jan Safranek <jsafrane@redhat.com> Signed-off-by: Dhaval Giani <dhaval@linux.vnet.ibm.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d6b28d3..8e2a40a 100644
--- a/configure.in
+++ b/configure.in
@@ -76,6 +76,20 @@ AC_ARG_ENABLE([daemon],
[with_daemon=true])
AM_CONDITIONAL([WITH_DAEMON], [test x$with_daemon = xtrue])
+socket_path="/var/run/cgred.socket"
+AC_ARG_ENABLE([cgred-socket],
+ [AC_HELP_STRING([--enable-cgred-socket=PATH],
+ specify location of cgrulesengd communication socket
+ (default=/var/run/cgred.socket))],
+ [
+ if test "x$enableval" = xno -o "x$enableval" = xyes; then
+ AC_MSG_ERROR([Provide valid path with --enable-cgred-socket option.])
+ else
+ socket_path="$enableval"
+ fi
+ ], [])
+AC_DEFINE_UNQUOTED([CGRULE_CGRED_SOCKET_PATH],"$socket_path", [Cgrulesengd socket path])
+
# Checks for programs.
AC_PROG_CXX
AC_PROG_CC