summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJan Safranek <jsafrane@redhat.com>2009-05-25 09:48:34 +0200
committerJan Safranek <jsafrane@redhat.com>2009-05-25 09:48:34 +0200
commit62e5d793d3d34479fec591dee62854381dc51291 (patch)
tree1c5ee0a288a5c6da051745df1df5eca7a7e3ec43 /configure.in
parent4a79706ce7f2e24dc7a028a42d2311aa885d77c3 (diff)
downloadlibcg-62e5d793d3d34479fec591dee62854381dc51291.tar.gz
libcg-62e5d793d3d34479fec591dee62854381dc51291.tar.xz
libcg-62e5d793d3d34479fec591dee62854381dc51291.zip
Add options to enable/disable various build targets.
By default, everything is compiled. I want to add options to ./configure, which can selectively disable tools, daemon and pam module. The library itself is mandatory component and cannot be disabled. Usage: ./configure --help ./configure --disable-tools --disable-pam --disable-daemon Signed-off-by: Jan Safranek <jsafrane@redhat.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 04afe31..b1bd2b5 100644
--- a/configure.in
+++ b/configure.in
@@ -37,6 +37,45 @@ AC_ARG_ENABLE([debug],
[Define to enable extra debugging output.])],
[])
+AC_ARG_ENABLE([tools],
+ [AC_HELP_STRING([--enable-tools],
+ [compile libcgroup tools [default=yes]])],
+ [
+ if test "x$enableval" = xno; then
+ with_tools=false
+ else
+ with_tools=true
+ fi
+ ],
+ [with_tools=true])
+AM_CONDITIONAL([WITH_TOOLS], [test x$with_tools = xtrue])
+
+AC_ARG_ENABLE([pam],
+ [AC_HELP_STRING([--enable-pam],
+ [compile libcgroup PAM module [default=yes]])],
+ [
+ if test "x$enableval" = xno; then
+ with_pam=false
+ else
+ with_pam=true
+ fi
+ ],
+ [with_pam=true])
+AM_CONDITIONAL([WITH_PAM], [test x$with_pam = xtrue])
+
+AC_ARG_ENABLE([daemon],
+ [AC_HELP_STRING([--enable-daemon],
+ [compile libcgroup daemon [default=yes]])],
+ [
+ if test "x$enableval" = xno; then
+ with_daemon=false
+ else
+ with_daemon=true
+ fi
+ ],
+ [with_daemon=true])
+AM_CONDITIONAL([WITH_DAEMON], [test x$with_daemon = xtrue])
+
# Checks for programs.
AC_PROG_CXX
AC_PROG_CC