summaryrefslogtreecommitdiffstats
path: root/talloc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'talloc/configure.ac')
-rw-r--r--talloc/configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/talloc/configure.ac b/talloc/configure.ac
new file mode 100644
index 000000000..60314dcc7
--- /dev/null
+++ b/talloc/configure.ac
@@ -0,0 +1,27 @@
+AC_PREREQ(2.50)
+AC_INIT(talloc, 1.2.0)
+AC_CONFIG_SRCDIR([talloc.c])
+AC_SUBST(datarootdir)
+AC_CONFIG_HEADER(config.h)
+
+AC_LIBREPLACE_ALL_CHECKS
+
+m4_include(libtalloc.m4)
+
+AC_PATH_PROG(XSLTPROC,xsltproc)
+DOC_TARGET=""
+if test -n "$XSLTPROC"; then
+ DOC_TARGET=doc
+fi
+AC_SUBST(DOC_TARGET)
+
+AC_LD_PICFLAG
+AC_LD_SHLIBEXT
+AC_LD_SONAMEFLAG
+AC_LIBREPLACE_SHLD
+AC_LIBREPLACE_SHLD_FLAGS
+
+m4_include(build_macros.m4)
+BUILD_WITH_BUILD_INST_DIR
+
+AC_OUTPUT(Makefile talloc.pc)