summaryrefslogtreecommitdiffstats
path: root/sss_client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sss_client/Makefile.am')
-rw-r--r--sss_client/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/sss_client/Makefile.am b/sss_client/Makefile.am
index 4552720ed..7333e4c39 100644
--- a/sss_client/Makefile.am
+++ b/sss_client/Makefile.am
@@ -1,9 +1,14 @@
SUBDIRS = po
+pipepath=@pipepath@
+
topdir=.
AM_CPPFLAGS = \
-I$(topdir) \
- -DLOCALEDIR=\"\$(localedir)\"
+ -DLOCALEDIR=\"\$(localedir)\" \
+ -DSSS_NSS_SOCKET_NAME=\"$(pipepath)/nss\" \
+ -DSSS_PAM_SOCKET_NAME=\"$(pipepath)/pam\" \
+ -DSSS_PAM_PRIV_SOCKET_NAME=\"$(pipepath)/private/pam\"
ACLOCAL_AMFLAGS = -I m4
AM_CFLAGS =