summaryrefslogtreecommitdiffstats
path: root/src/tests/cwrap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/cwrap/Makefile.am')
-rw-r--r--src/tests/cwrap/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/tests/cwrap/Makefile.am b/src/tests/cwrap/Makefile.am
new file mode 100644
index 000000000..34aec92c1
--- /dev/null
+++ b/src/tests/cwrap/Makefile.am
@@ -0,0 +1,47 @@
+AM_CPPFLAGS = \
+ -Wall \
+ -I$(top_srcdir)/src \
+ -I. \
+ $(DBUS_CFLAGS) \
+ $(NULL)
+
+TESTS_ENVIRONMENT = \
+ CWRAP_TEST_SRCDIR=$(abs_srcdir) \
+ . $(srcdir)/cwrap_test_setup.sh; \
+ $(AUX_TESTS_ENVIRONMENT) \
+ $(NULL)
+
+dist_noinst_SCRIPTS = \
+ cwrap_test_setup.sh \
+ $(NULL)
+
+dist_noinst_DATA = \
+ group \
+ passwd \
+ $(NULL)
+
+check_PROGRAMS =
+if HAVE_CMOCKA
+if HAVE_NSS_WRAPPER
+if HAVE_UID_WRAPPER
+check_PROGRAMS += become_user-tests
+endif # HAVE_UID_WRAPPER
+endif # HAVE_NSS_WRAPPER
+endif # HAVE_CMOCKA
+
+TESTS = $(check_PROGRAMS)
+
+become_user_tests_SOURCES = \
+ test_become_user.c \
+ $(NULL)
+become_user_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+become_user_tests_LDADD = \
+ $(POPT_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(abs_top_builddir)/libsss_debug.la \
+ $(abs_top_builddir)/libsss_test_common.la \
+ $(NULL)
+
+tests: $(check_PROGRAMS)