summaryrefslogtreecommitdiffstats
path: root/src/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/man/Makefile.am')
-rw-r--r--src/man/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/man/Makefile.am b/src/man/Makefile.am
index 6e23830a5..f0faf6900 100644
--- a/src/man/Makefile.am
+++ b/src/man/Makefile.am
@@ -6,13 +6,17 @@ top_builddir = ../..
############
-# If no conditions are given, *all* conditionals are expanded. We don't
+# If no conditions are given, *all* conditionals are expanded. We don't want
# to include any conditions by default, so we need to pass a phony conditional
-CONDS=with_false
if BUILD_SUDO
# conditionals are delimeted with a semicolon
-CONDS+=;with_sudo
+SUDO_CONDS = ;with_sudo
endif
+if BUILD_AUTOFS
+AUTOFS_CONDS = ;with_autofs
+endif
+CONDS = with_false$(SUDO_CONDS)$(AUTOFS_CONDS)
+
#Special Rules:
export SGML_CATALOG_FILES