summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d7a7a7705..da718eefa 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -135,6 +135,8 @@ AC_CHECK_HEADERS([sasl/sasl.h],,AC_MSG_ERROR([Could not find SASL headers]))
PKG_CHECK_MODULES([CHECK], [check >= 0.9.5], [have_check=1], [have_check=])
if test x$have_check = x; then
AC_MSG_WARN([Without the 'CHECK' libraries, you will be unable to run all tests in the 'make check' suite])
+else
+ AC_CHECK_HEADERS([check.h],,AC_MSG_ERROR([Could not find CHECK headers]))
fi
AC_PATH_PROG([DOXYGEN], [doxygen], [false])