summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 3c02f65a8..38b960889 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -133,12 +133,17 @@ dist_noinst_DATA = \
###############################
# Global compilation settings #
###############################
-COLLECTION_CFLAGS = \
- -I$(srcdir)/../common/collection \
- -I$(srcdir)/../common/trace
-COLLECTION_LIBS = \
- -L$(builddir)/../common/collection/.libs/ \
- -lcollection
+
+if HAVE_SYSTEM_COLLECTION
+ COLLECTION_CFLAGS = $(SYSTEM_COLLECTION_CFLAGS)
+ COLLECTION_LIBS = $(SYSTEM_COLLECTION_LIBS)
+else
+ COLLECTION_CFLAGS = \
+ -I$(srcdir)/../common/collection
+ COLLECTION_LIBS = \
+ -L$(builddir)/../common/collection \
+ -lcollection
+endif
INI_CFG_CFLAGS = \
-I$(srcdir)/../common/ini